Thread-2 NullPointerException

Post your questions regarding using the Vault and Fortress API in your programs.

Moderator: SourceGear


Posts: 38
Joined: Thu Jan 24, 2008 10:13 am
PostPosted: Mon Oct 29, 2012 12:27 pm
I'm adding 6.0 integration with our client. Any idea why I would be seeing this error when our client terminates?

Exception in thread "Thread-2" java.lang.NullPointerException
at system.Threading.Thread.setAppDomain(Thread.jvm.cs:1046)
at system.Threading.ThreadPool$WorkerThread.run(ThreadPool.jvm.cs:241)

I'm using the 6.0.1.598 Java API.

Thanks,
Eric

Posts: 3199
Joined: Tue Dec 16, 2003 1:17 pm
PostPosted: Mon Oct 29, 2012 12:52 pm
Eric,

Vault 6 updated the .NET to Java cross-compilation libraries, but no code has changed. We may need to do some debugging to track this down. Can you send an email to support at sourcegear dot com referencing this post, and we'll try to work from there.

Thanks.
Jeff Clausius
SourceGear

Posts: 38
Joined: Thu Jan 24, 2008 10:13 am
PostPosted: Mon Oct 29, 2012 1:33 pm
Thanks Jeff, will do.

Eric

Posts: 3199
Joined: Tue Dec 16, 2003 1:17 pm
PostPosted: Wed Nov 14, 2012 9:39 am
Eric,

With the help of some other partners, we were able to track down and fix some issues around Vault 6's Java to .NET bridge libraries. This fix will be released in Vault 6.1.

If you contact support, they should be able to get you a pre-release of Vault 6.1 for testing, and you could let us know if that resolved these issues.
Jeff Clausius
SourceGear

Return to Questions (API)

Who is online

Users browsing this forum: No registered users and 1 guest

cron