Search found 7 matches

by staggart
Fri Sep 25, 2009 10:22 am
Forum: Support (Fortress)
Topic: Need to add arbitrary files to existing repo
Replies: 1
Views: 2571

Need to add arbitrary files to existing repo

Hi, I have some automated build scripts which want to add and replace files in a subtree of a repo. Here's the problem. The first time ever through this script I can do an ADD of a complex folder containing subfolders, etc. and all is well - fortess does the add. The second time through, however, th...
by staggart
Fri Aug 14, 2009 4:56 pm
Forum: Support (Fortress)
Topic: Fortress Cache Corrupt When Move Fails
Replies: 1
Views: 2022

Fortress Cache Corrupt When Move Fails

When I move a folder in fortress 1.x and it fails (because there are files checked out in folder), I get a message saying the move failed (fine) but in tree view, it shows the folder as moved (bad) even though it has not in fact moved (i.e., when another user looks at the tree they see the unmoved f...
by staggart
Wed Jul 29, 2009 5:15 pm
Forum: Support (Vault)
Topic: How Expensive Are Labels?
Replies: 1
Views: 771

How Expensive Are Labels?

We want to do a nightly build of our source tree and label that tree as well. How expensive (both in time and space) is it to label the repo (say 30k files)? Will the labels slow down our fortress performance over time? Will our database grow a bunch for each label applied?
by staggart
Wed Jul 08, 2009 3:20 pm
Forum: Support (Fortress)
Topic: GETLABEL after directory move
Replies: 5
Views: 3686

Re: GETLABEL after directory move

OK, thanks. I did not try having the parent directory labeled. Your example seems to work. Thanks again.
by staggart
Tue Jul 07, 2009 10:22 am
Forum: Support (Fortress)
Topic: GETLABEL after directory move
Replies: 5
Views: 3686

Re: GETLABEL after directory move

no, it doesn't work for me. I get: running fortress command GETLABEL -verbose -makereadonly -merge overwrite -labelworkingfolder ./XXX $/ToolsAndUtilities/ATestFolderForGetLab el 12345 <vault> <error> <exception>System.Exception: No object was found at the repository path: $/ToolsAndUtilities/ATestF...
by staggart
Mon Jul 06, 2009 5:22 pm
Forum: Support (Fortress)
Topic: GETLABEL after directory move
Replies: 5
Views: 3686

GETLABEL after directory move

Hi,

Suppose I label a subtree named $/dev "12345" and later I move $/dev to $/xyz. What happens if I then do a GETLABEL on $/dev "12345"? Does it fail?

Thanks,

Scott
by staggart
Tue Jun 23, 2009 5:03 pm
Forum: Support (Fortress)
Topic: How do I script fortress?
Replies: 1
Views: 1869

How do I script fortress?

I would like to execute fortress commands from a batch/shell script on windows for automation purposes. I see no documentation for that (I found some for vault). How do I do that?

Thanks,

Scott