Search found 123 matches

by cs
Fri Feb 21, 2014 4:49 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

I managed to resolve this problem. It is related to a Win 2008 Server R2 IIS 7.5 application pool advanced setting. In IIS, select the app pool you wish to use for your web application, click right mouse, then Advanced Settings. Change the 'Load User Profile' setting to TRUE. The old VP client code ...
by cs
Thu Feb 20, 2014 6:31 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Whenever I am trying to log on from a new simple web site (using my own code), I receive this in the sgvault.log:

AuthTokenHash matched, but couldn't get the userid

Successful logins from the VP client (on the same server, same app pool) don't have that error.
by cs
Mon Feb 10, 2014 5:21 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Hi - I sent you the files as requested.

Is there any update?

Please let me know. Thanks !
by cs
Wed Feb 05, 2014 10:45 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

We still have the old Windows 2003 server with V6 code running fine. The new Win2k8 with 7.1 is a different machine which we are migrating to, due to the old one being deprecated. I tried to find out where the settings.xml file is on the old machine but had no success - couldn't find it :( So, As re...
by cs
Wed Feb 05, 2014 3:48 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Hi - Any help fixing this would be most useful. Our custom Vault Pro solution is unfortunately dead at the moment as we can't log in....

Am sure is something simple but our only option is to roll back to V6 unless we can resolve the error message.

Thanks !
by cs
Thu Jan 30, 2014 10:23 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Thanks for chasing this one up. Yes I have recompiled everything with the new DLL's. My code: VaultClientOperationsLib.LocalSettings.Init(LocalSettings.LocalSettingsScope.Admin ,"c:\\inetpub\\wwwroot\\website"); I set the correct perms for IIS_IUSRS and I now have a settings.xml being generated in t...
by cs
Tue Jan 28, 2014 3:14 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

There is a 'VaultAppPool' user. I found the LocalSettings method. The LocalSettings.LocalSettingsScope can be 'Client', 'IDE', or 'Admin'. Which of these 3 would be appropriate? Have set "C:\inetpub\wwwroot\VaultService\settings" as the second parameter. But - am still receiving access denied messag...
by cs
Mon Jan 27, 2014 12:32 pm
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

....OK thanks for getting back to me.

Which namespace is LocalSettings part of? I can't find it in the API documentation - sorry.

And, can this directory be UNC or a drive letter?
by cs
Mon Jan 27, 2014 5:58 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Forgot to say - we never call this: LocalSettings.Init()
by cs
Mon Jan 27, 2014 5:58 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Re: Settings.xml Local Settings Path

Yes - asp.net is installed and VP works fine via windows or web client. Sorry but - I can't find any reference to UtilityService or 'VaultSettingsXMLFileLocation' in our code. I think perhaps our code is quite a few years old and there may be some new options in the API. The client API DLL's are in ...
by cs
Fri Jan 24, 2014 9:20 am
Forum: Questions (API)
Topic: Settings.xml Local Settings Path
Replies: 18
Views: 26684

Settings.xml Local Settings Path

We have moved our VP server from 6.1 on Win2k3 to 7.1 on Win2k8. Our code which uses Mantis* is being tested. Error which I believe comes from ProcessCommandListFortressProjects is: Couldn't calculate a local settings path for settings.xml. Tried both "" and "SourceGear". Any suggested actions / tip...
by cs
Wed Sep 25, 2013 2:01 am
Forum: Support (Vault)
Topic: FogBugz integration question
Replies: 8
Views: 5935

Re: FogBugz integration question

Thanks for the information Linda. I notice there is integration with OnTime in the Vault documentation. Are there perhaps any plans to support any other agile tools, i.e. Version One or similar? VP is fine for change management but for development process something else is needed.. I wonder if any o...
by cs
Tue Sep 24, 2013 4:34 am
Forum: Support (Vault)
Topic: FogBugz integration question
Replies: 8
Views: 5935

Re: FogBugz integration question

Thread resurrection......... We are considering moving from Vault Pro to FogBugz (for work items, not source repo). Any feedback from users? And are there any improvements in FogBugz integrations coming in V7 of Vault Standard? Main reason is that we are moving to Version One and it has Fogbugz inte...
by cs
Tue Dec 18, 2012 10:54 am
Forum: Support (Vault Professional)
Topic: Query Projects Update/Pagination Hang
Replies: 5
Views: 4098

Re: Query Projects Update/Pagination Hang

Will do, likely be in early January. Problem is not critical.

By the way, if I click the 'Home' button when it is hung I get an error 500.

Thanks !
by cs
Tue Dec 18, 2012 10:33 am
Forum: Support (Vault Professional)
Topic: Query Projects Update/Pagination Hang
Replies: 5
Views: 4098

Re: Query Projects Update/Pagination Hang

Issue happens using IP and FQDN for server.

Using IE7 on server, IE8 on client.

Vault Pro 6.0.1.30598