Search found 487 matches

by mskrobul
Wed Nov 18, 2015 1:12 pm
Forum: Support (Vault Professional)
Topic: Vault 7.2.1 and VS2013 Integration
Replies: 5
Views: 4391

Re: Vault 7.2.1 and VS2013 Integration

Unfortunately, Visual Studio Express does not support any Source Control Plugins. VS Express has a limited feature set and that is a feature not offered in Express. You will need to use the stand alone Vault GUI client to perform Source Code operations if you use VS Express. Note that the VS 2013 co...
by mskrobul
Wed Nov 18, 2015 11:33 am
Forum: Support (Vault Professional)
Topic: Vault 7.2.1 and VS2013 Integration
Replies: 5
Views: 4391

Re: Vault 7.2.1 and VS2013 Integration

Are you using Visual Studio 2013 Express by any chance?
by mskrobul
Thu Aug 27, 2015 10:22 am
Forum: Support (Vault)
Topic: Saving a file Error
Replies: 2
Views: 3961

Re: Saving a file Error

Just to clarify - are you using the Classic Client or the Enhanced Client for Visual Studio Integration? Are you working in CVS mode or VSS mode? What type of file is failing on save? With regard to the icons, here is a KB article that describes the meaning of the different icons (assuming you are u...
by mskrobul
Wed Jul 08, 2015 3:16 pm
Forum: Support (Vault)
Topic: Vault 4.1 database backup failure
Replies: 7
Views: 7264

Re: Vault 4.1 database backup failure

Do you have enough disk space to perform the backup?

The sgvault database can be rather large.
by mskrobul
Wed Jul 08, 2015 2:10 pm
Forum: Support (Vault)
Topic: Vault 4.1 database backup failure
Replies: 7
Views: 7264

Re: Vault 4.1 database backup failure

The Vault Admin backup UI is basically just a wrapper for SQL server backup. The Vault Admin UI is there for convenience, but since the long backup process is done via a web request it can have issues for large databases etc. The Admin UI backup output is exactly the same as a normal SQL server back...
by mskrobul
Wed Jul 08, 2015 11:10 am
Forum: Support (Vault)
Topic: Upgrade Vault 6.01 to 8.0.1 on new server
Replies: 5
Views: 5222

Re: Upgrade Vault 6.01 to 8.0.1 on new server

Try clearing your browser cache. There were a lot of web UI changes made since 6.0.1 and your web browser may have old page data.
by mskrobul
Tue Jul 07, 2015 2:09 pm
Forum: Support (Vault)
Topic: Upgrade Vault 6.01 to 8.0.1 on new server
Replies: 5
Views: 5222

Re: Upgrade Vault 6.01 to 8.0.1 on new server

There shouldn't be any other intermediate installs necessary. You do not need to run the 7 and 8 installers on the existing Vault 6 machine first. You can just backup the databases, uninstall the Vault 6 server (make sure to KEEP your databases when prompted), then install Vault 7 (point to the SQL ...
by mskrobul
Tue Jul 07, 2015 1:44 pm
Forum: Questions (API)
Topic: Vault API fails on ProcessComandListFolder
Replies: 4
Views: 6690

Re: Vault API fails on ProcessComandListFolder

It is hard to say what is going on without looking at the rest of your code, but I just wrote this little test and ProcessCommandListFolder did work without any exceptions for this simple case: ServerOperations.SetLoginOptions("http://localhost/VaultService", "admin", "admin", "Initial Repository", ...
by mskrobul
Tue Jul 07, 2015 12:48 pm
Forum: Support (Vault)
Topic: Moving the vault website
Replies: 7
Views: 7441

Re: Moving the vault website

There should not be. That was an issue with installer software we no longer use. You can basically follow the instructions here (except you won't be moving the databases I assume): http://support.sourcegear.com/viewtopic.php?t=228 The server installer will create all the necessary app pools, applica...
by mskrobul
Tue Jul 07, 2015 9:46 am
Forum: Support (Vault)
Topic: Moving the vault website
Replies: 7
Views: 7441

Re: Moving the vault website

The easiest way would be to uninstall and re-install the Vault Server. Make sure to keep your databases when prompted by the uninstaller and the installer. When prompted by Server Installer for a website just choose the new website. That will make any future upgrades and uninstalls smoother.
by mskrobul
Tue Jul 07, 2015 9:24 am
Forum: Support (Vault)
Topic: Upgrd-Install Vault 3.1.9 to 5.1.2 from Win 2003 to 2008 R2
Replies: 1
Views: 3034

Re: Upgrd-Install Vault 3.1.9 to 5.1.2 from Win 2003 to 2008

All the history etc. is stored in the sgvault Database. Running the 5.1.2 server installer on the "new" machine will upgrade your 3.1.9 database to 5.1.2. The following KB article should help you out - it discusses moving the Vault Server to a new machine: http://support.sourcegear.com/viewtopic.php...
by mskrobul
Mon Feb 24, 2014 5:06 pm
Forum: Support (Vault)
Topic: Custom Date Fields
Replies: 3
Views: 3042

Re: Custom Date Fields

Custom field dates are stored in the database as .NET UTC ticks. For example to convert the database value to a date in C# you would first convert the string to a long, then use that value to create a DateTime object: //get the stringTicks from the database //convert the string to a long long longTi...
by mskrobul
Wed Feb 12, 2014 10:54 am
Forum: Support (Vault Professional)
Topic: Turn off the tooltips
Replies: 7
Views: 4667

Re: Turn off the tooltips

The "popup" tooltip functionality can be commented out in the Core.js file. Open the <VaultProServerDirectory>/Scripts/Core.js file on your server machine in an editor and comment out the following code (toward the bottom of the file): //make html titles look like nice tooltips $(document).tooltip({...
by mskrobul
Mon Aug 31, 2009 9:32 am
Forum: Support (Vault)
Topic: Installer error 2753 on Client 5.0.1 install via GPO
Replies: 9
Views: 3542

Re: Installer error 2753 on Client 5.0.1 install via GPO

The error that you referenced on the Advanced Installer forum was a completely different scenario even though it is the same error number. That particular error only occurred when the client installer was installed as part of the Server install and it has since been fixed. We changed the way the cli...
by mskrobul
Fri Aug 14, 2009 9:00 am
Forum: Support (Fortress)
Topic: Invalid Viewstate & Error 500 in version 2.0
Replies: 11
Views: 15234

Re: Invalid Viewstate & Error 500 in version 2.0

Can you send me entire sgfortress log file? You can use the email button to email me directly. So if you go to the server machine and use the http://localhost/fortress url you get the same bahavior? Have you tried making maxPageStateFieldLength a smaller number? When OS is your server running on? Ar...