Search found 21 matches

by grandavenuesoftware
Thu Aug 22, 2019 2:37 pm
Forum: Support (Vault)
Topic: Command Line Client Adding Folder Recursive
Replies: 5
Views: 259

Re: Command Line Client Adding Folder Recursive

I figured it out. The comment lost its quotes as I passed it through, so that's where Config came from. I should be able to finish it now. Thank you very much for your excellent support! (Being in a software company, I know how hard that is to provide.)
by grandavenuesoftware
Thu Aug 22, 2019 11:48 am
Forum: Support (Vault)
Topic: Command Line Client Adding Folder Recursive
Replies: 5
Views: 259

Re: Command Line Client Adding Folder Recursive

That worked. Now I'm getting an error when I try to check in from the script. This is the command: CHECKIN -comment "Jenkins Config Checkpoint" -verbose -resolvemerge $repositoryPath WARNING: <vault> <error> <exception>System.Exception: The current change set does not have any items for Config at Va...
by grandavenuesoftware
Wed Aug 21, 2019 4:36 pm
Forum: Support (Vault)
Topic: Command Line Client Adding Folder Recursive
Replies: 5
Views: 259

Command Line Client Adding Folder Recursive

I'm working on creating a script to snapshot our Jenkins configuration into vault so we can easily diff changes. I've got most of it working but I'm having issues with a new folder. When I encounter a new folder I do an ADD on the folder. Then I do an ADD on any contained files which also seems to a...
by grandavenuesoftware
Thu Oct 04, 2018 9:51 am
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

For anyone that has encountered a problem, a couple of questions so I may forward them to Microsoft's Visual Studio team: 1) What version and edition of Visual Studio or SSDT did this happen on? (Help... About information) We are running various 15.8.X versions (between 15.8.2 and 15.8.5) 2) Approx...
by grandavenuesoftware
Wed Sep 26, 2018 6:51 am
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

We will send a separate e-mail, as requested, as well. Posting here for any interested customers following along. *** Our next attempt is to disable the auto update of the extension. Please let me know the outcome. Turning off the auto update feature fixed the problem. The Task Scheduler history sho...
by grandavenuesoftware
Tue Sep 25, 2018 12:26 pm
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

Please let me know if this doesn't resolve the issue for you. The problem persists for multiple machines at our site. We have tried running vsixinstaller.exe as an Administrator, but that didn't do the trick. Our VS IDE always runs as Administrator. We have tried uninstalling the extension (as Admi...
by grandavenuesoftware
Mon Sep 17, 2018 9:53 am
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

Failed again this morning. It's odd, it's almost like it happens every 24 hours. I shut down yesterday, restarted last night and worked without issue. We see similar behavior. That is, re-installing provides a temporary fix, but the problem recurs eventually. Like adamsbrla, a reboot did not cause ...
by grandavenuesoftware
Mon Sep 10, 2018 3:07 pm
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

Reinstalling the extension appears to have fixed the issue.
by grandavenuesoftware
Mon Sep 10, 2018 2:56 pm
Forum: Support (Vault)
Topic: VS2017/Vault not binding
Replies: 27
Views: 11577

Re: VS2017/Vault not binding

We are also seeing this issue on multiple machines. Visuals Studio 2017 version is 15.8.3. Vault version is 10.0.1.793. We just noticed this behavior today. We will try the uninstall and re-install.
by grandavenuesoftware
Wed Aug 15, 2018 12:59 pm
Forum: Support (Vault)
Topic: Vault for Visual Studio Code
Replies: 13
Views: 11594

Re: Vault for Visual Studio Code

We are now using Visual Studio Code to edit some of our PowerShell scripts. We would be in favor of a vault plug-in for Visual Studio Code. VS Code is gaining popularity so it may be something for you to consider in a future release.
by grandavenuesoftware
Tue Jun 30, 2015 12:57 pm
Forum: Support (Vault)
Topic: Windows 10
Replies: 15
Views: 16347

Windows 10

We are running Vault 8.0.1 and are considering upgrading a couple of development machines to Windows 10 as soon as it is released. Will Windows 10 run the client (including Visual Studio integration) correctly? Are you aware of any issues?

Thanks in advance,

John Somsky
by grandavenuesoftware
Thu Jan 10, 2013 4:38 pm
Forum: Support (Vault)
Topic: CCNET not retrieving latest version
Replies: 25
Views: 17730

Re: CCNET not retrieving latest version

It might be helpful to determine why the Get is failing. Could there be hardware or network problems? Are there any errors in the Vault server log or in the event viewer that explain the failed Get? We did activate verbose debugging. At some point a particular cruise control project will start givi...
by grandavenuesoftware
Thu Jan 10, 2013 1:51 pm
Forum: Support (Vault)
Topic: CCNET not retrieving latest version
Replies: 25
Views: 17730

Re: CCNET not retrieving latest version

It might be helpful to determine why the Get is failing. Could there be hardware or network problems? Are there any errors in the Vault server log or in the event viewer that explain the failed Get? We haven't found any evidence of hardware or network problems. The two machines (client and vault se...
by grandavenuesoftware
Wed Jan 09, 2013 2:03 pm
Forum: Support (Vault)
Topic: CCNET not retrieving latest version
Replies: 25
Views: 17730

Re: CCNET not retrieving latest version

CCNET communicates with the Vault Plugin and the plugin uses a history command to check the latest version in the repository. If the version has been updated, CCNET triggers a build. Then the plugin does a GET. Currently, if the GET fails, we have no way to stop CCNET from continuing with the build...
by grandavenuesoftware
Wed Jan 02, 2013 9:57 am
Forum: Support (Vault)
Topic: CCNET not retrieving latest version
Replies: 25
Views: 17730

Re: CCNET not retrieving latest version

humphry wrote:I'm more interested in the fact that the plugin continues in case of exceptions.
We don't need to run two services, so that is irrelevant.
Ditto.