Search found 11 matches

by bastress
Mon Sep 17, 2018 6:40 am
Forum: Support (Vault)
Topic: Repository Cache Keeps Growing
Replies: 1
Views: 2617

Repository Cache Keeps Growing

Hello, The Vault cache files are not being cleared by Vault and keep adding over time. We need to clear out these files and limit the number of cache files it keeps. I tried to change the Vault Cache options but it did not work on the server, maybe because we use command line to get the code? Also, ...
by bastress
Tue Aug 21, 2018 6:37 am
Forum: Support (Vault)
Topic: Fogbugz integration Bug
Replies: 9
Views: 4463

Re: Fogbugz integration Bug

Thank you. Do we extract this overtop the vault folder where we extracted the last TLS1.2 client?
by bastress
Mon Aug 20, 2018 12:36 pm
Forum: Support (Vault)
Topic: Fogbugz integration Bug
Replies: 9
Views: 4463

Re: Fogbugz integration Bug

Using the TLS1.2 version... Getting this error when executing the Vault.exe commands from PowerShell. Unhandled Exception: System.BadImageFormatException: Could not load file or assembly 'VaultClientOperationsLib, Version=10.0.0.736, Culture=neutral, PublicKeyToken=e372e94840f8a4d3' or one of its de...
by bastress
Wed Aug 15, 2018 1:35 pm
Forum: Support (Vault)
Topic: Fogbugz integration Bug
Replies: 9
Views: 4463

Re: Fogbugz integration Bug

The Vault client you provided did indeed fix the TLS communication problem and is now posting to Fogbugz. Thank you. Now we just need to get the URL encoding problem fixed.
by bastress
Wed Aug 15, 2018 9:52 am
Forum: Support (Vault)
Topic: Fogbugz integration Bug
Replies: 9
Views: 4463

Re: Fogbugz integration Bug

Hmm I was looking for a way to post a pic. Well anyway we are using Vault 10. In FogBugz if you open a case and click on the Checkin link, a box pops up which says 'Checkins for Case #####'. There are two links in the box. one for VaultHistory.aspx the other link for VaultDiff.aspx. Links with more ...
by bastress
Wed Aug 15, 2018 7:44 am
Forum: Support (Vault)
Topic: Fogbugz integration Bug
Replies: 9
Views: 4463

Fogbugz integration Bug

So we have the FogBugz integration setup with Vault and thought it had been working at one point. However recently notice that only 10% of the check-ins seem to be linking back to FogBugz. After some investigation, it appears only the check-ins from visual studio to vault are being linked, and all c...
by bastress
Mon Apr 16, 2018 8:30 am
Forum: Support (Vault)
Topic: Wait timeout for mutex after 30000 milliseconds
Replies: 8
Views: 5273

Re: Wait timeout for mutex after 30000 milliseconds

sent to support@
sourcegear.com
by bastress
Mon Apr 16, 2018 6:50 am
Forum: Support (Vault)
Topic: Wait timeout for mutex after 30000 milliseconds
Replies: 8
Views: 5273

Re: Wait timeout for mutex after 30000 milliseconds

I have some additional information. The developer before me wrote a plugin for Jenkins to handle the vault interaction. It does not look like we are using PowerShell. Here is some of the relevant vault client code... package hudson.plugins.vault; import hudson.FilePath; import hudson.Launcher; impor...
by bastress
Thu Apr 12, 2018 7:36 am
Forum: Support (Vault)
Topic: Wait timeout for mutex after 30000 milliseconds
Replies: 8
Views: 5273

Re: Wait timeout for mutex after 30000 milliseconds

Windows Server 2012 R2 We are using Windows PowerShell in Jenkins We are using the Vault command line client that comes with the GUI Client. 10.0.0.736 I am not entirely sure when the issue started. I see the problem in the earliest build we have saved, about a month ago. We have three executors set...
by bastress
Wed Apr 11, 2018 2:02 pm
Forum: Support (Vault)
Topic: Wait timeout for mutex after 30000 milliseconds
Replies: 8
Views: 5273

Re: Wait timeout for mutex after 30000 milliseconds

We did test this and had no issues. We tried opening more then one command window as well and executing several at once. All returned fine each time we tried. This test was done on the Jenkins server where the builds are processed using the same user.
by bastress
Wed Apr 11, 2018 12:51 pm
Forum: Support (Vault)
Topic: Wait timeout for mutex after 30000 milliseconds
Replies: 8
Views: 5273

Wait timeout for mutex after 30000 milliseconds

Hi we have been experiencing a new issue over the last several weeks that appears to be getting worse. During our build process we are seeing: 10:35:25 Exit code -1 unsuccessful; throwing IOException: <vault> 10:35:25 <error> 10:35:25 <exception>System.Exception: Wait timeout for mutex after 30000 m...