Search found 99 matches

by avonwyss
Tue Sep 14, 2010 1:04 pm
Forum: Questions (API)
Topic: ProcessCommandGetVersionToLocationOutsideWorkingFolder issue
Replies: 3
Views: 5683

Re: ProcessCommandGetVersionToLocationOutsideWorkingFolder issue

I'm not sure about the exact version, but I did get unexpected files in there.

Basically I would like to know if I'm using the correct version or if I should use another one? Since my code is somewhat complex I might need some time to isolate the problem more.
by avonwyss
Tue Sep 14, 2010 11:24 am
Forum: Questions (API)
Topic: ProcessCommandGetVersionToLocationOutsideWorkingFolder issue
Replies: 3
Views: 5683

ProcessCommandGetVersionToLocationOutsideWorkingFolder issue

I'm trying to get the files in a folder as they were at a specific time, just like the "View Tree" / "Get Tree" operations in the Vault client. I'm currently trying this: VaultTxHistoryItem[] txHistoryItems = ServerOperations.ProcessCommandVersionHistory(...) This gives me the list of folder version...
by avonwyss
Wed Sep 16, 2009 12:19 pm
Forum: Support (Vault)
Topic: WebDAV Vault 5.0.1: Invalid credentials are not well handled
Replies: 6
Views: 1858

Re: WebDAV Vault 5.0.1: Invalid credentials are not well handled

I gave "Everyone" rights to the keys, as suggested.

We have a domain account for Vault and I've done the install just the same as 5.0.0. The account used for installation was a administrator account.
by avonwyss
Tue Sep 15, 2009 3:18 am
Forum: Support (Vault)
Topic: WebDAV Vault 5.0.1: Invalid credentials are not well handled
Replies: 6
Views: 1858

Re: WebDAV Vault 5.0.1: Invalid credentials are not well handled

Generally the solution is to add Read/Write/Modify permissions to %ALLUSERSPROFILE%\Application Data\Microsoft\Crypto\RSA\MachineKeys Done that on the server, and it seems to fix the issue. What is unclear to me is why the installer has nod done this in the first place while updating, I'm pretty su...
by avonwyss
Mon Sep 14, 2009 10:44 am
Forum: Support (Vault)
Topic: Vault 5.0.1: Find Shelveset - Creator Drop-Down behavior
Replies: 1
Views: 768

Vault 5.0.1: Find Shelveset - Creator Drop-Down behavior

There is a drop-down "Creator:" in the "Find Shelveset" dialog. Unfortunately, selecting a user by typing a name does not work; while the name can by typed in, it has no effect on the selected creator, making it pretty unefficient for keyboard users. Also, I'd like to have a client option not to dis...
by avonwyss
Mon Sep 14, 2009 9:34 am
Forum: Support (Vault)
Topic: WebDAV Vault 5.0.1: Invalid credentials are not well handled
Replies: 6
Views: 1858

Re: WebDAV Vault 5.0.1: Invalid credentials are not well handled

I tried getting a file through a web browser, and I think I mistyped the password. What I got back was an empty page, instead of the expected password dialog again. Therefore, I took WFetch to see what happens, and that's what I've posted here. Edit: maybe WebDAV doesn't work at all on our server wi...
by avonwyss
Mon Sep 14, 2009 8:51 am
Forum: Support (Vault)
Topic: WebDAV Vault 5.0.1: Invalid credentials are not well handled
Replies: 6
Views: 1858

WebDAV Vault 5.0.1: Invalid credentials are not well handled

If there are problems with the credentials, the WebDAV client does not give a 40x error, but fails with a 500 error: GET /sgdav/wd.ashx/site/repository/ HTTP/1.1 Host: www.sirius.ch Accept: */* Authorization: Basic xxxxxxxxxxxxxxxxxxxxxxxxxxx RESPONSE: HTTP/1.1 500 Internal Server Error Date: Mon, 1...
by avonwyss
Tue Sep 01, 2009 8:18 am
Forum: Support (Vault)
Topic: Installer error 2753 on Client 5.0.1 install via GPO
Replies: 9
Views: 3919

Re: Installer error 2753 on Client 5.0.1 install via GPO

Maybe you could consider testing it. Because it is a nightmare to run to each machine and platform to update vault clients, if it could just happen automatically when logging onto a machine. By the way, I just logged into an old XP client and wonderfully got Vault 5.0.1 installed during logon. There...
by avonwyss
Mon Aug 31, 2009 9:37 am
Forum: Support (Vault)
Topic: Installer error 2753 on Client 5.0.1 install via GPO
Replies: 9
Views: 3919

Re: Installer error 2753 on Client 5.0.1 install via GPO

Other GPO installs work fine.

Also, UAC is mostly disabled on those dev machines (automatic elevation without prompt, always run as real admin, no virtual registry).

Installing the same MSI (from the identical location on the network) manually works fine.
by avonwyss
Mon Aug 31, 2009 1:38 am
Forum: Support (Vault)
Topic: Installer error 2753 on Client 5.0.1 install via GPO
Replies: 9
Views: 3919

Re: Installer error 2753 on Client 5.0.1 install via GPO

There seems to be no such file; I even re-ran the install and searched the complete hard disk for it.
by avonwyss
Thu Aug 27, 2009 3:09 am
Forum: Support (Vault)
Topic: 1011: FailInvalidSessionToken after hibernate (S4)
Replies: 3
Views: 1316

Re: 1011: FailInvalidSessionToken after hibernate (S4)

The server looses the session tokens if rebooted. This has nothing to do with he state of the client (if it was left running, you would get the same behavior). In older versions of the VSIP client, you'd get a more descriptive error message followed by the login dialog and after that you could conti...
by avonwyss
Thu Aug 27, 2009 3:04 am
Forum: Support (Vault)
Topic: Shell Extension for Vault
Replies: 3
Views: 1399

Re: Shell Extension for Vault

...add my vote as well please. :)
by avonwyss
Thu Aug 27, 2009 2:22 am
Forum: Support (Vault)
Topic: Installer error 2753 on Client 5.0.1 install via GPO
Replies: 9
Views: 3919

Installer error 2753 on Client 5.0.1 install via GPO

In order to keep our developers at the current release of Vault I have set up a software deployment via Group Policy for Vault. This used to work just fine with Vault 4.x and Windows XP. In the meantime, we have got new workstations with Windows Vista x64. I'm therefore not sure if the problem also ...
by avonwyss
Sat Aug 15, 2009 11:18 am
Forum: Support (Vault)
Topic: Vault 5 VSIP client - "Open from Vault" does nothing
Replies: 3
Views: 1268

Re: Vault 5 VSIP client - "Open from Vault" does nothing

Yes, solutions work fine.

I'm using VS2008 with all updates installed.