Search found 32 matches

by djMax
Tue Jun 14, 2005 2:02 pm
Forum: Gold Support (Vault) -- Read-only
Topic: Client API, labels, and "as of" fetching
Replies: 3
Views: 2260

Client API, labels, and "as of" fetching

I'm writing a tool to help prop web sites more simply. Basically it's an executable that "gets latest" via the API. I would like to be able to get historical versions either by label or by "version as of 1/1/05 12:30 EST" kind of thing. The second one is probably harder, but I can't even figure out ...
by djMax
Tue Jun 14, 2005 1:56 pm
Forum: Gold Support (Vault) -- Read-only
Topic: Vault client API error
Replies: 2
Views: 1769

Registering 3.1 in the GAC fixed the problem, though it's cause still eludes me.
by djMax
Sun Jun 12, 2005 9:22 am
Forum: Gold Support (Vault) -- Read-only
Topic: Vault client API error
Replies: 2
Views: 1769

Vault client API error

I'm getting this error: File or assembly name VaultLib, or one of its dependencies, was not found. at System.Reflection.CustomAttribute.CreateCAObject(Int32& propNum, Assembly& assembly)\r\n at System.Reflection.CustomAttribute.GetObject()\r\n at System.Reflection.CustomAttribute.CheckConsistencyAnd...
by djMax
Wed Feb 09, 2005 11:38 pm
Forum: Gold Support (Vault) -- Read-only
Topic: VS2005 / Whidbey and Vault
Replies: 2
Views: 2432

Very exciting news, thanks for it. Will the 3.1 beta work with the 3.0 server? If so I'd like to give it a shot, I'll figure out how to message you and then do so. :)
by djMax
Fri Feb 04, 2005 10:16 am
Forum: Gold Support (Vault) -- Read-only
Topic: VS2005 / Whidbey and Vault
Replies: 2
Views: 2432

VS2005 / Whidbey and Vault

So as we all know Vault and Whidbey/VS2005 don't like each other so much. I have it limping along at the moment, so long as I never use the Vault client itself, and use a totally separate respository, it mostly works. But my general issue is that given that as developers we need to be out in front o...
by djMax
Mon Dec 06, 2004 9:54 am
Forum: Support (Dragnet)
Topic: Workflow ?
Replies: 5
Views: 7664

I might suggest implementing this as a client side Javascript function if you want it before they can get to it... It wouldn't be hard I don't think, and that's one of the great things about the architecture, that you can do that...
by djMax
Fri Dec 03, 2004 10:40 am
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

My pleasure, "Reflector" is a very cool program. :)
by djMax
Thu Dec 02, 2004 9:01 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

Ok, thanks. Pressure is off for me, I switched Vault and Dragnet to Windows auth and forced SSL for everything, so we're good to go now.
by djMax
Thu Dec 02, 2004 1:19 pm
Forum: Support (Dragnet)
Topic: Only Issue - External Submissions
Replies: 7
Views: 9171

I'll toss in my opinion that this is the #1 missing feature from Dragnet right now... Especially when compared to FogBugz's great email integration. The solution proposed with a consumable web service is a nice one because it might allow SourceGear to get the rest of the community to do the work for...
by djMax
Thu Dec 02, 2004 9:10 am
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

Vault auth.

And it seemed to work for a while after I logged the "impersonated" user for vault in, but not for long.

This is almost definitely a keyset problem, my guess is in SGAuth.EncryptPassword (and potentially elsewhere). I think the RSAParameters need to have "use machine keyset" set.
by djMax
Wed Dec 01, 2004 7:27 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

Yeah, I think that was the problem... Is there a reason you're not using the Machine Keyset in the code?

I logged into the machine interactively as the Vault user once, and now it works.
by djMax
Wed Dec 01, 2004 7:23 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

I think that is only used for SOS, so disregard... But perhaps this might lead to something?

http://support.microsoft.com/default.as ... us;Q322371
by djMax
Wed Dec 01, 2004 7:09 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

might this have something to do with a file called BF.dll, which I assume implements BlowFish, which I cannot find on my disk anywhere but is referenced from your code?
by djMax
Wed Dec 01, 2004 6:33 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

Nope, installed SP1, same problem. Turned the debug level up to "debug", but still nothing too useful other than: Vault authorization for user max failed. Couldn't connect to object. CryptoAPI cryptographic service provider (CSP) for this implementation could not be acquired. 2004-12-01 19:26:28.984...
by djMax
Wed Dec 01, 2004 5:57 pm
Forum: Gold Support (Dragnet) -- Read-only
Topic: Vault/Dragnet integrated authentication problem
Replies: 14
Views: 15933

It's Windows Server 2003 (SBS). I just went to winupdate and it seems I don't have .Net 1.1 SP1. Let me install that and see if that fixes it.