Search found 252 matches

by mlippert
Wed Mar 01, 2006 4:34 pm
Forum: Gold Support (Vault) -- Read-only
Topic: New keyword vote
Replies: 3
Views: 1907

James, Can you tell me exactly how a $label$ keyword would work? In other words where does its expanded value come from when you check-in (which is when keywords are currently expanded, although I think it would make more sense to expand them on get). I don't think I've ever applied a label to a sin...
by mlippert
Tue Feb 21, 2006 1:22 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

For those following this topic: Linda and I have been trying different things and I've been sending lots of log files, but nothing has helped. Today, I decided to test the theory that there were 2 issues, the 1st Art encountered with the old client, and the 2nd with the new client. And that the issu...
by mlippert
Thu Feb 16, 2006 10:48 am
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Linda, Jeff,
I hate to be a nudge, but did the log files I sent give you any ideas on what the problem is? This is really hurting our build process.

If there's some other thing we should try (reboot the server again?) or information we can collect (DB query?) let me or Art know.

Thanks,
Mike
by mlippert
Wed Feb 15, 2006 11:24 am
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Linda, The server has had debug logging on this whole time (if you wanted to see a sample of the huge number of entries for Get Latest Version I can post them). I've just started the test with the client set up to log everything. I'll extract the bottom of the server log, and zip it along with the c...
by mlippert
Tue Feb 14, 2006 6:29 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Jeff, OK get label from the server following those same steps failed in the same way. Started the Vault 3.1.7 GUI client on the Vault Server machine, specifying 127.0.0.1 as the server. Set the working folder for our Trunk to a directory that doesn't exist, and let Vault create it for me. Right-clic...
by mlippert
Tue Feb 14, 2006 5:20 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Jeff, I'm going to try the get label from the server just as a final verification. However it doesn't make sense to be that there is something blocking Get Label traffic and letting Get Latest Version traffic through. Could this be a problem with 3.1.7 client and 3.1.6 server interaction? I just did...
by mlippert
Tue Feb 14, 2006 10:53 am
Forum: Support (Vault)
Topic: How to Integrate WinMerge
Replies: 3
Views: 1525

Linda, This raises a question I've been wondering about. Changing the merge tool in the options doesn't change what the Merge Branches Wizard uses for automatic merging does it? And actually, does it change what Vault uses when it needs to do an automatic merge during a Get Latest Version (when Atte...
by mlippert
Mon Feb 13, 2006 5:32 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Debug logging on the server is on. That's what provided the errors I listed in the 1st msg in this topic.

Art's gone for the day, I will get together with him and do it again in the morning.

Mike
by mlippert
Mon Feb 13, 2006 4:00 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

What's odd about this though is that it works fine getting a branch of the trunk. Art runs almost the same exact script to build various branches.

FYI our server is 3.1.6 and I think Art just updated his client to 3.1.7.

Could he turn on any client side logging that would be helpful?

Mike
by mlippert
Fri Feb 10, 2006 5:16 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Thanks Linda,
I'll tell Art. I expect that we won't get back to this until Monday, at which time I hope that I'll have figured out what one of our Gold Subscription license numbers are (I only know the expired numbers) so that Art can enable his account for this forum and continue this directly.

Mike
by mlippert
Fri Feb 10, 2006 4:57 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Posting for Art while we try to find our current gold subscription code for his account. I laid the label down via a perl script which call a vault command line. It seemed to operate completely normally and without error ... and it the exact process I've been using for days. When trying to get from ...
by mlippert
Fri Feb 10, 2006 1:54 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

Linda,
I'm fairly sure that he's using a script that uses the commandline client. I'm going to tell him to post a reply here.

Mike
by mlippert
Fri Feb 10, 2006 12:15 pm
Forum: Gold Support (Vault) -- Read-only
Topic: FailInvalidLabelObjID
Replies: 26
Views: 9938

FailInvalidLabelObjID

----2/10/2006 9:58:16 AM RelEng--southwind.widget.com(xxx.xx.x.xx)--SSL Disabled VaultLib.VaultRequestGetFile returned: FailInvalidLabelObjID ... (many of the above lines) ----2/10/2006 9:58:16 AM RelEng--southwind.widget.com(xxx.xx.x.xx)--SSL Disabled BeginDownloadLabelFiles returned: FailDBLookup...
by mlippert
Thu Feb 09, 2006 1:47 pm
Forum: Support (Vault)
Topic: Primary Share a tree of folders and files
Replies: 8
Views: 3961

From what I've heard, "Get Latest Version" from 2 different repository folders into the same working folder (particularly when files in the 2 folders have the same name) is a recipe for problems.

I'm not sure what those problems are, perhaps someone at SourceGear could comment?

Mike
by mlippert
Tue Feb 07, 2006 1:09 pm
Forum: Support (Vault)
Topic: Show Labels needs sorting and filtering
Replies: 1
Views: 1774

Show Labels needs sorting and filtering

I just found out that a while ago I had labeled the wrong version of our Trunk (for a branch). In general it is best to create the label and then branch the label, but I forgot that and created the branch directly from the folder, and added the label later. I found out that I had labeled the wrong v...