SoS Server 'hangs' while checking-in

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear


Posts: 2
Joined: Fri Apr 07, 2006 8:40 am
PostPosted: Fri Apr 07, 2006 8:48 am
I recently solved the problem of concurrent users connecting to SoS and the SoS server dying, but now i've managed to find another problem. Basically the server 'hangs' while files are being checked in. I have an excerpt from the log.

Restarting the SoS server service got it working again.

Any ideas / info?

Thanks,

Justin Strauber

4/7/2006 7:24:42 AM - 37: vssver.scc is a SourceSafe local cache file and cannot be added. (8004d81e)
4/7/2006 7:25:55 AM - Exception in Receive(): An existing connection was forcibly closed by the remote host
4/7/2006 7:25:55 AM - 4/7/2006 7:25:55 AM - Server Exception (400): OPERATION_FAILED
4/7/2006 7:25:55 AM - 37: Server Error: 400
4/7/2006 7:25:55 AM - 37: Error removing user temp folder 'C:\Program Files\SourceOffSite Server\temp\carl632799909013281250'.
4/7/2006 7:25:55 AM - The process cannot access the file "CBDocument.pas.gz" because it is being used by another process.
4/7/2006 7:26:08 AM - Connection accepted from 192.168.65.4:2957 on local address 10.0.20.10:8081, session id is 38.
4/7/2006 7:26:12 AM - 38: Unable to get hostname from address: 192.168.65.4
4/7/2006 7:26:40 AM - 38: An item with the name $/APokerSource/NextRelease already exists (8004d694)
4/7/2006 7:26:40 AM - 38: An item with the name $/APokerSource/NextRelease/Design Ideas.doc already exists (8004d694)
4/7/2006 7:26:40 AM - 38: vssver.scc is a SourceSafe local cache file and cannot be added. (8004d81e)
4/7/2006 7:26:40 AM - 38: An item with the name $/APokerSource/NextRelease/Browser already exists (8004d694)
4/7/2006 7:26:40 AM - 38: An item with the name $/APokerSource/NextRelease/Browser/CBConnection.pas already exists (8004d694)
4/7/2006 7:28:11 AM - Exception in Receive(): An existing connection was forcibly closed by the remote host
4/7/2006 7:28:11 AM - 4/7/2006 7:28:11 AM - Server Exception (400): OPERATION_FAILED
4/7/2006 7:28:11 AM - 38: Server Error: 400
4/7/2006 7:28:11 AM - 38: Error removing user temp folder 'C:\Program Files\SourceOffSite Server\temp\carl632799915735468750'.
4/7/2006 7:28:11 AM - The process cannot access the file "CBDocument.pas.gz" because it is being used by another process.
4/7/2006 7:28:20 AM - Connection accepted from 192.168.65.4:2978 on local address 10.0.20.10:8081, session id is 39.
4/7/2006 7:28:25 AM - 39: Unable to get hostname from address: 192.168.65.4
4/7/2006 7:28:44 AM - 39: vssver.scc is a SourceSafe local cache file and cannot be added. (8004d81e)
4/7/2006 7:29:22 AM - 39: Exception: Index was outside the bounds of the array.

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Mon Apr 10, 2006 10:07 am
What version of SOS Server and Client are you using? Is the checkin from the GUI Client or from the IDE (Visual Studio).

Is this happening to one user or all users?
Linda Bauer
SourceGear
Technical Support Manager

Posts: 2
Joined: Sat Mar 03, 2018 8:19 pm
PostPosted: Sat Mar 03, 2018 8:26 pm
Hi,
I am also occur this issue,use Client and add from GUI Client.

Thanks,
Best Regards.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon Mar 05, 2018 4:54 pm
Which version of SourceOffSite are you using?

If you restart the SOS service like the previous user did, does it allow you to check in after that?
Beth Kieler
SourceGear Technical Support

Posts: 2
Joined: Sat Mar 03, 2018 8:19 pm
PostPosted: Tue Mar 06, 2018 6:29 pm
Hi Beth,
Sorry,there may be some misunderstanding,
I'm use Microsoft Visual SourceSafe Explorer - 32-bit
Visual SourceSafe Version 8.0.50727.42

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 07, 2018 8:58 am
The forums you are posting to are for the product SourceOffSite, which connects to a Visual SourceSafe server. If you're using strictly Visual SourceSafe, then you'll want to look to Microsoft. I'm not sure why VSS might hang.

[On a personal side note, I'd run Analyze and install the VSS Update available from Microsoft, but I don't know if that would solve the issue. Finding your VSS log files would be the next thing you do to see if there are errors you can google.]
Beth Kieler
SourceGear Technical Support

Return to Support (SourceOffSite)

Who is online

Users browsing this forum: Exabot [Bot] and 3 guests

cron