SOS 5.0.1 on Win7/64 - Autologin problem

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

Post Reply
craighann
Posts: 11
Joined: Wed Nov 11, 2009 7:23 am

SOS 5.0.1 on Win7/64 - Autologin problem

Post by craighann » Wed Nov 11, 2009 8:03 am

Hi,

I've having an issue with SOS 5.0.1 when starting the SOS client. On starting the client, it attempts to log in automatically to our server, but fails with the message "The server was unable to connect to the SourceSafe database. Check your server's log file for additional information."

If I try and log in with "Connect Automatically" checked on the "Connect To Server" dialog, it fails with the same message.

If I uncheck this, so that I get challenged for my username and password, it works fine *without* me re-entering my username/password, so I know the cached credentials are valid.

I'm getting the same behaviour whether I use the "Recent Server Activity" list or "Open Server Connection". I've tried running SOS as Administrator, and in Compatibility mode with Vista and XP, but I still get the same error.

Regards,
Craig.

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 on Win7/64 - Autologin problem

Post by jclausius » Wed Nov 11, 2009 8:02 pm

Did you have a previous version of SOS installed? If so, SOS 5 may be reading from the SOS 4 settings, and the options there may not be correct.

SOS 5 will read/save SOS 4 options in HKCU\Software\SourceGear\SourceOffSite\Settings. There will be some string values in the registry for Connections (Connection0, Connection1, Connection2, etc.) You should be able to verify the data for your server here. If there is a problem, we may want to look at changing the cached values within the registry.

Also note, the SOS 4 options for a VSS database within the connect string may not match the VSS database set up with SOS 5. It could be a string mis-match problem causing the issues with the cached values. Comparing the data in here with the databases set in your SOS Server manager may shed some light on the problem.
Jeff Clausius
SourceGear

Post Reply