SOS 5.0.1 Get again

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

Post Reply
Jared Sullivan
Posts: 81
Joined: Sun Aug 06, 2006 12:51 am

SOS 5.0.1 Get again

Post by Jared Sullivan » Sun Nov 15, 2009 4:25 pm

Get on folder (recursive) doesn't flag files as READ-ONLY. However everything works if a GET is performed on file list.

NOTE to repo bug you have to GET from 2 folders up of your file list. i.e. A Get Latest on the folder "project" recursvly [\project\source\*.* ] will fail to flag all files in \source as read-only.

Natarually files didn't exist when task was performed.

Can this be fixed in 5.0.2?

Thanks
Jared Sullivan

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 Get again

Post by jclausius » Mon Nov 16, 2009 9:02 am

Jared,

Just to clarify... The files exist on disk in these sub folders as they were retrieved with a "GET" by SOS, but the read-only file attribute was turned off at some point. So when the secondary GET is performed, although no files were retrieved, the read-only flag attribute remains unset?

Is that correct?
Jeff Clausius
SourceGear

Jared Sullivan
Posts: 81
Joined: Sun Aug 06, 2006 12:51 am

Re: SOS 5.0.1 Get again

Post by Jared Sullivan » Mon Nov 16, 2009 12:34 pm

Jeff...The files don't exist on disk, when a GET is done through SOS on a folder for files in sub folder(2 deep), the files are created by SOS *without* READ ONLY flag.

Bug synopsis = "GET on GrandParent folder where local copies of files in child folder are not present leads to creation of files with no read only flag set"

Thanks
Jared Sullivan

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 Get again

Post by jclausius » Wed Nov 18, 2009 11:09 am

Jared, I'll have someone dig into this. Thanks for the report.
Jeff Clausius
SourceGear

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 Get again

Post by jclausius » Thu Jan 28, 2010 11:19 am

Jared,

I could not repro this problem with a pre-release 5.0.2 client. The only thing I did see in my testing was if a GET was performed on missing files, and they were checked out, the files *did not* have the RO flag set. However, if the GET was performed on missing files, and they were NOT checked out, the RO attribute was set.

The key is if the files were checked out or not checked out.
Jeff Clausius
SourceGear

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 Get again

Post by jclausius » Thu Jan 28, 2010 11:49 am

Jared,

QA went back and tried the problem with SOS 5.0.1 Build 242, and it DOES exist there. So this problem has been addressed in the soon to be released 5.0.2 client.
Jeff Clausius
SourceGear

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5.0.1 Get again

Post by jclausius » Wed Mar 31, 2010 10:43 am

Jared,

The read-only issue for missing files has been addressed in SOS 5.0.2. Look for the maintenance release to be out today (March 31, 2010).
Jeff Clausius
SourceGear

Post Reply