Is there a TimeOut Setting? v5.0.3

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear


Posts: 93
Joined: Tue Mar 25, 2008 1:27 pm
PostPosted: Wed Feb 27, 2013 12:13 pm
Is there some kind of a timeout setting for Source Offsite. It seems that I lose my connection to SourceOffsite when I try to check out a file that has been loaded into Visual Studio for quite some time (several hours) I frequently get prompted, after a delay, with “Do you want to reconnect to the server?

Thank you.
Brian C Drab

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Feb 27, 2013 1:47 pm
There is a setting in the SOS Server Manager called Timeout Idle Connections that you might have set. That's under the General Settings tab.

Another thing to try is to use the Keep Alive setting in the client. In the client Tools - Options under General is the Keep Alive.
Beth Kieler
SourceGear Technical Support

Posts: 93
Joined: Tue Mar 25, 2008 1:27 pm
PostPosted: Thu Feb 28, 2013 3:05 pm
The Timeout Idel Connections was not set.

So we tried the Keep Alive setting on the client and it only seemed to make it worse. Any other suggestions?

Thank you.
Brian C Drab

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri Mar 01, 2013 10:57 am
What do you have the Keep Alive set for and how did it make it worse?
Beth Kieler
SourceGear Technical Support

Posts: 93
Joined: Tue Mar 25, 2008 1:27 pm
PostPosted: Fri Mar 01, 2013 4:25 pm
The default of 2 minutes.

Visual Studio locks up every time we try to check in or undo check out. More info. The issue appears to only happen when the user is connected via VPN from home. When he is in the office, the issue doesn't occur.
Brian C Drab

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 06, 2013 10:02 am
The VPN could be dropping packets. Might check for that.
Beth Kieler
SourceGear Technical Support

Return to Support (SourceOffSite)

Who is online

Users browsing this forum: No registered users and 5 guests

cron