Server sessions keeps timing out

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 2448
Joined: Wed Dec 17, 2003 5:03 pm
Location: SourceGear
PostPosted: Thu May 13, 2004 9:52 am
Link to Session Timeouts on Windows 2008/2012

Under Win2k3 and IIS 6
When you run the Vault service on Windows 2003 Server, IIS 6 is used to run Vault, which is much more aggressive about timing out user sessions and recycling the server (causing all user sessions to end).

By default, IIS 6 will recycle the Vault service every 29 hours (regardless of whether anyone has recently made a request to the server). When IIS restarts Vault, all Vault users must login again.

The following changes can be made to IIS and Vault settings ensure that the Vault Service only logs you out after a period of inactivity:

From the IIS Manager, go to Application Pools->DefaultAppPool->Properties (by right clicking).

1. Under recycling, uncheck all recycling options. These options will automatically recycle (meaning kill and restart) the Vault server, based on the values presented, and don't depend on inactivity by users. It is OK to leave these values on if you <b>want</b> to recycle the server periodically.

2. Under the Performance pane, set the value you want for "Shutdown worker process after being idle" (or turn it off completely). Note that this is not a per session timeout, but when to recycle the server after no one has accessed it for the specified number of minutes.

3. From the Web Sites->Vault Site tree node in the IIS Manager, right click on Properties and go to the Home Directory pane. Press the Configuation button, and then go to the Options pane on that dialog. By default, the session timeout value there is 20 minutes. This value is supposed to be overridden by the Vault Session timeout (below), but it doesn't hurt to set it to the same value you have the Vault Admin Tool.

4. The Vault Session Timeout in the Vault Admin Tool (in the Server Options pane) still controls the per-user session timeout. The session will be timed out if there is no activity for a given user within the number of minutes specified. This does not recycle the server.

Note that if you are timed out more frequently than the Vault Session Timeout, it is likely the server is being recycled by IIS by one of the options above.

If you are timed out less frequently than the time specified, it is likely that your client options are set to automatically refresh your client every X minutes, so the session isn't really idle.

Also, see the following MSDN article for information on the IIS worker process settings:
http://msdn.microsoft.com/library/defau ... ttings.asp

If all else fails, there are two additional steps that may help:

1. Turn off keep-alives in IIS. Go to the properties of the Vault website and go to the Web Site tab. There is a checkbox there to disable HTTP keep-alives.

2. Put IIS 6.0 in to IIS 5.0 isolation mode. This will apply to all services running on IIS, but should ensure that Vault runs properly. Please note this is only supported in versions prior to Vault 3.5.3.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Jun 05, 2013 9:57 am
Under Windows 2008/2012 and IIS 7.x

In Windows 2008/2012, you can make the following changes to prevent server sessions from timing out.

1) Open the Windows IIS Manager. Expand the Machine name and click on Application Pools. Click on the VaultAppPool and then click the Recycling link on the right under Edit Application Pool.
Recycling.png
Recycling.png (11.21 KiB) Viewed 7341 times


2) Turn off the recycling options for Regular time intervals, Fixed number of requests, Visual memory usage, and Private memory usage.

3) Either turn off the Specific time(s) option or set it to a time when users will not be using Vault.

4) Change the recycling options for the SgDavAppPool, VaultIndexAppPool, VaultNotifyAppPool, and the VaultShadowFolderAppPool if they are present.

5) IIS will assign an application pool to each website. The application pool assigned to the website that Vault is installed to will also need to have its recycling options turned off or adjusted.

6) Next, for the same application pools you just checked, go to the Advanced Settings. Under Process Model, make sure the Idle Timeout is set to 0. Do this for each application pool.

7) The Vault Session Timeout in the Vault Admin Tool (in the Server Options pane) still controls the per-user session timeout. The session will be timed out if there is no activity for a given user within the number of minutes specified. This does not recycle the server.
Beth Kieler
SourceGear Technical Support

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: No registered users and 8 guests

cron