Welcome to the Vault/VaultPro Visual Studio Enhanced Client

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
PostPosted: Wed Apr 29, 2009 3:03 pm
You've successfully rebound your projects and solutions to the Vault/VaultPro Visual Studio Enhanced client. What's next?

  • You can read the FAQ. We've rounded up the most common questions you might have.
  • You can start working. Follow the instructions below to see two ways to get started.
  • You can search for support. You are currently at our support forum. If you have questions, we will be happy to answer them here.

Thanks for using Vault and VaultPro
Getting started with a bound project - Method 1

The first method will always work. The principle is to use the GUI client to arrange your working folders, get the files to disk, and then open the solution like you would any other file on your hard drive.

After you've installed the Client on your development machine, open it, and log into your server.

Below is solution that I've added to the server, and bound to the Enhanced client, but haven't opened yet.

opening01.png
opening01.png (169.4 KiB) Viewed 5089 times


Set a working folder for the top folder.

opening02.png
opening02.png (237.04 KiB) Viewed 5089 times


If some of my projects need to have working folders that aren't under the solution, this is the point where you would set those.

opening03.png
opening03.png (223.58 KiB) Viewed 5089 times


Now do a get latest.
opening04.png
opening04.png (248.85 KiB) Viewed 5089 times


Now open the solution from Windows Explorer.
opening05.png
opening05.png (147.27 KiB) Viewed 5089 times


You'll be prompted to log in, and now you can check out and check in changes to this solution right from Visual Studio.
opening06.png
opening06.png (224.63 KiB) Viewed 5089 times


Getting started with a bound project - Method 2

The second method will work most of the time.

Open Visual Studio, and make sure that our enhanced client is the default Source Control provider. From the Tools menu, select Options. In the options dialog select Source Control, and pick the Enhanced Client from the plug-in list.
opening07.png
opening07.png (308.01 KiB) Viewed 5085 times


Now, in the File menu's Source Control option, then Open From.
opening08.png
opening08.png (249.6 KiB) Viewed 5085 times


You'll be prompted to log in, and choose a repository. In the Open From dialog, browse to the location of your solution file.
opening09.png
opening09.png (147.3 KiB) Viewed 5085 times


You may be prompted to set a working folder. Now your project is open. If you don't see the Pending Change View, select the View Menu, then Vault or Fortress, then the Pending Changes option.
opening10.png
opening10.png (439.42 KiB) Viewed 5083 times
Subscribe to the Fortress/Vault blog

Posts: 3490
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Thu Aug 24, 2017 3:25 pm
One other addendum regarding the Vault / Vault Pro Enhanced Client.

If you're solution requires a mixture of some 'Bound' projects and other projects which will not be in Vault's source control, you can try the following steps:

1) Add the solution and desired projects to Vault via the GUI client.

2) Open up the solution from within Visual Studio. From the File Menu, choose SourceGear Vault (Pro) Source Control, and then "Change Bindings".

3) On the Change Bindings dialog, do not Bind the solution, as once a solution is bound, all sub-projects are bound. Instead, choose the projects you want to be under version control, and then "bind" each of those individually. This will prompt for a repository location where the project file can be found. Choose the correct folder, and then choose OK.

This should now allow you to have a mixture of projects that are bound and unbound. However, note any changes you wish to push through to Vault will need to be done with the Vault GUI or Vault command line client.

Further note, it is unknown if these steps will work where the Visual Studio project type has no corresponding project file, for example a Web Site. In a case like this, the Solution will most likely have to be bound.
Jeff Clausius
SourceGear

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: No registered users and 3 guests

cron