Error with the encrypted password for the sgvaultuser

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Mon Nov 02, 2009 4:52 pm
If you are installing Vault 4.1.x on Windows 2008 64-bit or Windows 2003 64-bit and you are using SQL Server authentication, you may encounter this error in the Vault log when attempting to log in.

Could not load connect string. There is probably an error with the encrypted password for the sgvaultuser database user. Contact technical support at http://support.sourcegear.com

The Vault 4.1.4 installer does not write the sgvaultuser encryption information to the proper registry key in 64-bit systems.

The workaround would be to use Windows authentication for SQL Server, or modify the registry.

Here are the steps to modify the registry:

Using the info in CryptoKey and CryptoInitVector keys and their values from HKEY_LOCAL_MACHINE\SOFTWARE\SourceGear\Vault Server, manually create the same CryptoKey and CryptoInitVector keys and copy and paste the values to

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SourceGear\Vault Server 64-bit

Leave the CryptoKey and CryptoInitVector keys in HKEY_LOCAL_MACHINE\SOFTWARE\SourceGear\Vault Server

Rename HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SourceGear\Vault Server 64-bit to
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SourceGear\Vault Server (delete the "64-bit")

Restart IIS and your web browser. You should now be able to log in.

This bug has been fixed in Vault 5.0
Linda Bauer
SourceGear
Technical Support Manager

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: No registered users and 8 guests