Access denied attempting to launch a DCOM Server

A collection of information about SourceOffSite, including solutions to common problems.

Moderator: SourceGear

Post Reply
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Access denied attempting to launch a DCOM Server

Post by lbauer » Tue Feb 17, 2004 8:52 am

Error: "Access denied attempting to launch a DCOM Server" when trying to start the SOS Server service.

The SOS Server is not a DCOM Server ... nor does it use DCOM.

Is the SOS Server on the same machine as the VSS database?

If so, I would suggest you try changing the account running the Server
service. The Server service can be run under any domain account that
has full access to the machine/drive containing the VSS database

You may also want to search through your System Registry on the classID
listed in the Event log. This search may point to the DCOM Server that is
having problems.

The following Microsoft Knowledge Base article contains information which
should help in getting rid of this error: ... bContent=1

One of our other customers had the same error and the classID pointed to
the debug manager. The problem was solved by removing the debug
manager. There seems to be a link with starting the Server service and
seeing this error. We just don't know what that link could be. The SOS
Server should not be accessing the MDM Utilities.
Linda Bauer
Technical Support Manager

Post Reply