"an exception that could not be handled"

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear


Posts: 8
Joined: Fri May 04, 2007 5:18 pm
PostPosted: Mon Apr 28, 2008 6:29 pm
I just installed Vault client (3.5.1, from our server/vaultservice).

I am getting this error:
VaultGUIClient.exe - Common Language Runtime Debugging Services
Application has generated an exception that could not be handled.
Process id=0x638(1592), Thread id=0x62c(1580).

I uninstalled, searched for vault client cache at %USERPROFILE%\Local settings\Application Data\etc. (none found), removed Vault client entries from registry, rebooted, and tried to reinstall. Same problem.

I am running MS Windows XP Pro SP2 with all updates on a Pentium M, 2 GHz.

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Tue Apr 29, 2008 7:14 am
At what point in using the client do you get this error?
Are you able to view the information under Help->Technical Support?
If so, post that info here.
Linda Bauer
SourceGear
Technical Support Manager

Posts: 8
Joined: Fri May 04, 2007 5:18 pm
PostPosted: Tue Apr 29, 2008 8:45 am
I get the error at the startup of the client before I am able to do anything.

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Tue Apr 29, 2008 12:36 pm
Perhaps client-side logging will help:

http://support.sourcegear.com/viewtopic.php?t=1534

Note, you won't be able to use the shortcut logging, since you can't launch the client, but modify the VaultGUIClient.exe.config to enable logging. Log All classes.

Also, could you post a screenshot of the crash error?
Linda Bauer
SourceGear
Technical Support Manager

Posts: 8
Joined: Fri May 04, 2007 5:18 pm
PostPosted: Tue Apr 29, 2008 6:27 pm
Attached:

screenshot of failure
modified VaultGUIClient.exe.config

I attempted to turn on logging for all classes, but I was not able to find any log file.
Attachments
VaultGUIClient.exe.config.txt
Modified config file.
(3.5 KiB) Downloaded 664 times
screenshot.JPG
screenshot of the failure
screenshot.JPG (50.87 KiB) Viewed 10130 times

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Wed Apr 30, 2008 3:16 pm
This looks like a problem with the .NET Framework. Vault 4.x uses the 2.0 Framework.

Can you run the Vaut Command Line Client? As a test, from a command prompt, CD to the Vault GUI Client directory and type "vault.exe help" (no quotes).
Linda Bauer
SourceGear
Technical Support Manager

Posts: 8
Joined: Fri May 04, 2007 5:18 pm
PostPosted: Wed Apr 30, 2008 3:45 pm
I invoked the command line client, resulting in an exception and the following output:

C:\Program Files\SourceGear\Vault Client>vault.exe help

Unhandled Exception: System.IO.FileNotFoundException: File or assembly name System, or one of its dependencies, was not found.
File name: "System"
at VaultLib.SimpleLogger.ConfigureFromAppSettings(String programName)
at VaultCmdLineClient.VaultCmdLineClient.Main(String[] args)

=== Pre-bind state information ===
LOG: DisplayName = System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b
77a5c561934e089
(Fully-specified)
LOG: Appbase = C:\Program Files\SourceGear\Vault Client\
LOG: Initial PrivatePath = NULL
Calling assembly : VaultLib, Version=3.5.1.4786, Culture=neutral, PublicKeyToken
=a74d7badb9387c36.
===

LOG: Publisher policy file is not found.
LOG: Host configuration file not found.
LOG: Using machine configuration file from c:\WINDOWS\Microsoft.NET\Framework\v1
.1.4322\config\machine.config.
LOG: Post-policy reference: System, Version=1.0.5000.0, Culture=neutral, PublicK
eyToken=b77a5c561934e089
LOG: Attempting download of new URL file:///C:/Program Files/SourceGear/Vault Cl
ient/System.DLL.
LOG: Attempting download of new URL file:///C:/Program Files/SourceGear/Vault Cl
ient/System/System.DLL.
LOG: Attempting download of new URL file:///C:/Program Files/SourceGear/Vault Cl
ient/System.EXE.
LOG: Attempting download of new URL file:///C:/Program Files/SourceGear/Vault Cl
ient/System/System.EXE.
Attachments
exception.JPG
exception.JPG (98.6 KiB) Viewed 10106 times

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Wed Apr 30, 2008 9:04 pm
I'd suggest reinstalling the .NET Framework 1.1 on the machine.
Linda Bauer
SourceGear
Technical Support Manager

Posts: 8
Joined: Fri May 04, 2007 5:18 pm
PostPosted: Thu May 01, 2008 9:37 am
Thank-you. That worked.

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Mon May 05, 2008 12:28 pm
You're welcome. :)
Linda Bauer
SourceGear
Technical Support Manager

Return to Gold Support (Vault) -- Read-only

Who is online

Users browsing this forum: No registered users and 5 guests

cron