Vault - failed server connection

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
apepper
Posts: 12
Joined: Tue Jun 01, 2004 8:17 am
Location: United Kingdom

Vault - failed server connection

Post by apepper » Tue Jun 08, 2004 8:18 am

We have imported our database from sourcesafe and te create more space on the c drive of the server as we kept running out of space we uninstalled sourcesafe. I now get the following error :
The vault server could not establish a connection to the database. Please check the servers log for detailed information (FailDbConn)
I cannot access the database or the admin tool. cry:

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Post by jeremy_sg » Tue Jun 08, 2004 8:21 am

Have you looked at the vault server log in c:\windows\temp\sgvault\sgvault.log?

Also, look at item 4 on this page:

http://support.sourcegear.com/viewtopic.php?p=2450

apepper
Posts: 12
Joined: Tue Jun 01, 2004 8:17 am
Location: United Kingdom

Vault - failed server connection

Post by apepper » Tue Jun 08, 2004 9:08 am

Yes we have checked this and we can not access our database, is there a way that when we imported the database it defaulted to the C(4Gb)drive, withtin sql we are trying to make it store the whole database on D which has more than enough space(80Gb). We are currently trying to restore the database now. Is there anything you can suggest please find attached log file. :?
HELP!!!!!!

jclausius
Posts: 3649
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Post by jclausius » Tue Jun 08, 2004 9:59 am

How are you attempting to move the database?

Are you using Backup / Restore? Detach / Attach?
Jeff Clausius
SourceGear

jclausius
Posts: 3649
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Post by jclausius » Tue Jun 08, 2004 10:01 am

Also, before posting sgvault.log, rename it to something like sgvault.log.txt. This forum won't add files which have .log as the extension
Jeff Clausius
SourceGear

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Post by jeremy_sg » Tue Jun 08, 2004 10:19 am


apepper
Posts: 12
Joined: Tue Jun 01, 2004 8:17 am
Location: United Kingdom

Vault - failed server connection

Post by apepper » Wed Jun 09, 2004 2:39 am

My Database has been restored in SQL but when I try and login to the Admin tool or the client it still comes up with same message. It is like it cannot see or connect to the Database in sql
:cry:
The vault server could not establish a connection to the database. Please check the servers log for detailed information (FailDbConn)
At present the only way I can meet my deadline is to probably wipe the server and the initial import again from sourcesafe.

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Post by jeremy_sg » Wed Jun 09, 2004 6:08 am

Please email me your phone number. I'll contact you as soon as possible to try to resolve this issue. If the database has been restored, then we should be able to figure this out fairly quickly.

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Post by jeremy_sg » Wed Jun 09, 2004 9:28 am

I've spoken wit apepper, and since reinstalling the Vault server, they needed help with resetting the activation key. I did that. She is going to send me a copy of the sgvault log file to make sure that if there is a new issue with moving the database, we can watch for it in the future.

Locked