Duplication of Users in Admin GUI (2.0.6)

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
mrswoop
Posts: 3
Joined: Mon Feb 21, 2005 11:57 pm
Location: Seattle, WA
Contact:

Duplication of Users in Admin GUI (2.0.6)

Post by mrswoop » Thu Feb 24, 2005 8:05 am

We are beginning to add additional repositories to our installation, and creating standard groups to define access to each repository. Yesterday, suddenly, I began seeing usernames duplicated in areas in the Admin client (User tab, Edit Group dialog/Assign users to group list). In general, things seem to work OK if I select only the first instance of a username... but on occasion it does cause client errors (1104: Fail DBReader).

*Note: I had a group named with an underscore prefix "_Freeze", merely to sort it at the top of the list. Renaming this group without the underscore seems to have fixed the duplicate issue in the User tab.

Separate but related item... selecting "<All>" as a choice for "View only users in group"causes the following error:

An unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will be shut down immediately.

Specified cast is not valid.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Feb 24, 2005 8:31 am

I was able to reproduce the Admin Tool crash in Vault 3.0.2 when selecting All.

We'll look into this further.

I didn't have a problem when I created a group with an underscore for the first character. Is the duplicate name problem reproducible on your end?
Linda Bauer
SourceGear
Technical Support Manager

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Feb 24, 2005 8:46 am

Followup: the crash occurs when when there's a group with an underscore for the first character.
Linda Bauer
SourceGear
Technical Support Manager

mrswoop
Posts: 3
Joined: Mon Feb 21, 2005 11:57 pm
Location: Seattle, WA
Contact:

Post by mrswoop » Thu Feb 24, 2005 1:51 pm

Yes... we still have the duplicat users issue. I also figured out that the underscore was related to the exception so I've taken care of that. I'm attaching a screenshot so you can see what we have here.
Attachments
VaultAdmin.GIF
Duplicate usernames in Admin Client (2.0.6)
VaultAdmin.GIF (25.26 KiB) Viewed 4504 times
<b>Scott Willhite</b>
<a href="http://www.dotnetnuke.com">DotNetNuke</a>
Proud users of Vault

mrswoop
Posts: 3
Joined: Mon Feb 21, 2005 11:57 pm
Location: Seattle, WA
Contact:

Any information on this one yet?

Post by mrswoop » Sun Feb 27, 2005 7:45 pm

Hey Linda... just wondered if you guys had any insight into this yet. I've not experienced any data loss that I am aware of... but when my Source Control is doing things like this it makes me nervous *grin*.
<b>Scott Willhite</b>
<a href="http://www.dotnetnuke.com">DotNetNuke</a>
Proud users of Vault

Locked