History does not show correct timestamp for label operations

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
popezilla
Posts: 57
Joined: Tue Jul 13, 2004 1:17 pm
Location: MD
Contact:

History does not show correct timestamp for label operations

Post by popezilla » Tue May 16, 2006 3:32 pm

The timestamp I see in the history for a label operation is different from the actual time the label operation was completed. It seems to show the same timestamp as the last checkin operation.

I've attached a screen shot which shows what I am seeing. Here is a breakdown of my operation times and what the vault client log shows and what the history viewer shows.

Create Table.sql
Log shows 5:10:30, History shows 5:10:30

Checkin Table.sql
Log shows 5:10:55, History shows 5:10:55

Label Table.sql - v2
Log shows 5:12:08, History shows 5:10:55

Check in Table.sql
Log shows 5:13:26, History shows 5:13:26

Label Table.sql - v3
Log shows 5:14:46, History shows 5:13:26
Attachments
VaultHistory.JPG
VaultHistory.JPG (131.09 KiB) Viewed 2679 times

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Tue May 16, 2006 3:57 pm

If you look at labels in History Explorer, the label time is the same as the time of the version that was labeled. This is to keep the label action close to the version it is labeling.

However "Show Labels" shows the actual time of the label.

For example if FolderA was last updated Dec 1, 2005, and you label the folder on May 1, 2006, the label date in History will be Dec 1, 2005. However the date of the label in Show Labels will be May 1, 2006.
Linda Bauer
SourceGear
Technical Support Manager

dan
Posts: 2448
Joined: Wed Dec 17, 2003 5:03 pm
Location: SourceGear
Contact:

Post by dan » Tue May 16, 2006 4:08 pm

In the currently version of Vault, the label dates in the History Dialog are displayed as the version date they were applied at, not the date the label was applied. This was to ensure that labels are ordered correctly in the history dialog (so, for example, if you label an older version, the sort order would be incorrect in that the label would not appear next to the version it is applied to).

This will be fixed in 3.5, where we will display the date it was labelled on, but order it by the version number it applies to.

Sorry this is confusing. For the time being, the Show Labels dialog will show the date the label was applied.

Locked