Unsetworkingfolder uppercase/lowercase problem

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear


Posts: 55
Joined: Wed Mar 31, 2004 6:25 am
PostPosted: Sat Jun 30, 2007 5:08 am
Hi,
I want to use the unsetworkingfolder command from command-line, but are having problems when my repository path are not identical with regards to uppercase/lowercase characters.

    vault.exe *** setworkingfolder $/Folder/Sms/Source/Sms D:\Folder\Sms\Source\Sms
    Result: <workingfolder reposfolder="$/Folder/sms/source/Sms" localfolder="D:\Folder\Sms\Source\Sms" />
    vault.exe *** unsetworkingfolder $/Folder/Sms/Source/Sms
    Result: <workingfolder reposfolder="$/Folder/sms/source/Sms" localfolder="D:\Folder\Sms\Source\Sms" />
    If I use this command everything will work: vault.exe *** unsetworkingfolder $/Folder/sms/source/Sms

How can I make my repository path uppercase/lowercase independent?
I am using Vault v4.0.1

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Sat Jun 30, 2007 9:16 pm
I'm having trouble reproducing this. What operating system is your Vault client on?

Is there any error message? Or are the working folders just not set or unset?
Linda Bauer
SourceGear
Technical Support Manager

Posts: 55
Joined: Wed Mar 31, 2004 6:25 am
PostPosted: Sun Jul 01, 2007 11:36 pm
We are using a Win2003 Standard server for this task.

Code: Select all
vault.exe *** setworkingfolder $/Octopus/Sms/Source/Sms D:\Polaris\Octopus\Sms\Source\Sms
<vault>
  <listworkingfolders>
    <workingfolder reposfolder="$/Octopus/sms/source/Sms" localfolder="D:\Polaris\Octopus\Sms\Source\Sms" />
  </listworkingfolders>
  <result>
    <success>True</success>
  </result>
</vault>

Code: Select all
vault.exe *** unsetworkingfolder $/Octopus/Sms/Source/Sms
<vault>
  <listworkingfolders>
    <workingfolder reposfolder="$/Octopus/sms/source/Sms" localfolder="D:\Polaris\Octopus\Sms\Source\Sms" />
  </listworkingfolders>
  <result>
    <success>True</success>
  </result>
</vault>

The exact folder in Vault is: $/Octopus/sms/source/Sms
It seems like your unsetworkingfolder command is sensitive to uppercase/lowercase? How can I make this not case sensitive?

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Mon Jul 02, 2007 1:59 pm
I was able to reproduce this -- let me make sure I understand the problem:

The exact folder in Vault is: $/Octopus/sms/source/Sms

If you use $/Octopus/Sms/Source/Sms, in the unsetworkingfolder command, the working folder is NOT unset, despite the "success" message.

If you use $/Octopus/sms/source/Sms, the working folder IS unset.

Is that correct?

I don't know why this is case sensitive. I'll log it as a bug, and we'll have our developers take a look at it.

In the meanwhile you'll need to use the exact case of the Vault folder and subfolders in your command.
Linda Bauer
SourceGear
Technical Support Manager

Posts: 55
Joined: Wed Mar 31, 2004 6:25 am
PostPosted: Mon Jul 02, 2007 11:22 pm
Thank you - you have identified my problem.
Looking forward to a Vault upgrade that will fix this bug :D

Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
PostPosted: Fri May 30, 2008 3:35 pm
4.1.2 fixes this problem.
Subscribe to the Fortress/Vault blog

Return to Gold Support (Vault) -- Read-only

Who is online

Users browsing this forum: No registered users and 6 guests

cron