Visual Studio .NET 2003 Enterprise

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
ByDesignTechnologies
Posts: 9
Joined: Thu Jul 05, 2007 8:16 pm

Visual Studio .NET 2003 Enterprise

Post by ByDesignTechnologies » Thu Jul 05, 2007 8:20 pm

I have both VS 2005 and VS 2003 installed on all developers' machines.

Switching back and forth between Microsoft Visual Source Safe and SourceGear Vault is fairly simple and straight forward in VS 2005.

Am I missing something for VS 2003? When I go to Tools >> Options >> Source Control..... I do not see an option for Vault. Is there something special for VS 2003 installations?

Please help!

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Fri Jul 06, 2007 8:32 am

In the Vault GUI client, under tools->-options-> General, make sure that you have selected Vault as your default source control provider.

Also make sure Vault appears under this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\SourceCodeControlProvider
Linda Bauer
SourceGear
Technical Support Manager

ByDesignTechnologies
Posts: 9
Joined: Thu Jul 05, 2007 8:16 pm

Post by ByDesignTechnologies » Fri Jul 06, 2007 8:42 am

Vault is my default provider.

Within the registry, I have 3 keys in that folder.

- (Default) = (value not set)
- ProviderRegKey = Software\Microsoft\SourceSafe
- ProviderRegKey_BeforeVault = Software\Microsoft\SourceSafe

Then, there are two folders.

- InstalledSCCProviders (Both VSS and Vault in here)
- Options

Vault isn't even an option in the source control providers list within VS 2003, but it is in the list for VS 2005.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Fri Jul 06, 2007 8:49 am

Try changing this:

- ProviderRegKey = Software\Microsoft\SourceSafe

to this:

- ProviderRegKey = Software\Microsoft\Vault Client
Linda Bauer
SourceGear
Technical Support Manager

ByDesignTechnologies
Posts: 9
Joined: Thu Jul 05, 2007 8:16 pm

Post by ByDesignTechnologies » Thu Aug 02, 2007 4:39 am

Still not working. I just updated my client to 4.0.3 and I still do not have SourceGear Vault in my list of available source control providers in my installation of Visual Studio 2003.

But, my installation of VS 2005 has a few new options. I am attaching screen shots of both.

Should I uninstall VS 2003 and try reinstalling it, then Vault client?
Attachments
vs2003.JPG
VS 2003
vs2003.JPG (47.38 KiB) Viewed 6590 times
vs2005.JPG
VS 2005
vs2005.JPG (49.17 KiB) Viewed 6590 times

Terence
Posts: 164
Joined: Thu Feb 02, 2006 2:43 pm
Location: SourceGear

Post by Terence » Thu Aug 02, 2007 9:21 am

The list of SCC providers In Visual Studio 2003, doesn't work the same as it does in Visual Studio 2005.

For Visual Studio 2003, the only way to enable Vault as the SCC provider, is to use the Vault GUI Client and enable the "Make Vault your default SCC Provider" check box.

Locked