Minor Problem with VS 2005

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
chris.bradley
Posts: 30
Joined: Tue Aug 15, 2006 6:17 pm

Minor Problem with VS 2005

Post by chris.bradley » Wed Aug 29, 2007 9:01 am

We're currently running vault version 3.5 and a small problem I have occurs when you're using Visual Studio 2005 and you choose to Open a Project from source control.

The vault "Connect to Server" dialog box pops-up on top of visual studio. Life's good, I'm opening 5 other apps at the same time and when I remember to go back to Visual Studio to select my profile in the dialog I choose Visual Studio on the Task Bar and the "Connect to Server" dialog is brought to the front.

But! If I get to the "Choose Repository" dialog and then move over to another app, when I choose Visual Studio on the task bar that "Choose Repository" dialog does NOT come up. Instead I need to minimize every app I have open until I can find that dialog box.

It's not the end of the world but every time it happens I'm thrown off-course while I try and sort it out. Is there any chance you could find out why it doesnt work like the "Conntact to Server"? As an alternative, could you show that dialog in the task bar? Either way it would stop me from losing that dialog.

Oh, and by the way... why does the Automatic Connect using Profile no longer work? I check this setting in Vault Gui CLient but it never seems to make a difference to either VS2005 or Vault Gui Client.
[/img]
Attachments
vaultConnectDialog.jpg
vaultConnectDialog.jpg (206.82 KiB) Viewed 4104 times
vaultMissingDialog.jpg
vaultMissingDialog.jpg (291.12 KiB) Viewed 4104 times
vaultFoundIt.jpg
vaultFoundIt.jpg (265.89 KiB) Viewed 4104 times

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed Aug 29, 2007 12:55 pm

I can't answer yet on the first part of your question. On the second part, check that the MSSCCPRJ.SCC has the information it needs for which profile to select. See this article here for more information:
http://support.sourcegear.com/viewtopic.php?t=2474

In Vault, it won't skip the login, but you would select the profile, and the automatic connect should be which repository to connect to.

In Visual Studio, when you open something new, it checks the first time.

I don't have any reports of it not working in that version of Vault. What was it doing for you before you moved to Vault 3.5.x?

chris.bradley
Posts: 30
Joined: Tue Aug 15, 2006 6:17 pm

Post by chris.bradley » Wed Aug 29, 2007 1:35 pm

I can't say for sure how it worked before 3.5 - I didn't really pay attention but for some reason I thought that even the prompt when creating a new solution from Vault was skipped if you had a default profile selected. I'm not really sure though so it's not too big a deal.

Locked