Ghosted Files and Folders Stopped Working

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
Tom.Wells
Posts: 65
Joined: Tue Sep 21, 2004 10:35 am

Ghosted Files and Folders Stopped Working

Post by Tom.Wells » Mon Sep 24, 2007 9:41 am

I have been using ghosted files and folders since we installed 3.5.1. Today I noticed that it has stopped working. I unchecked and rechecked the options, rebooted, and nothing has helped.

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Mon Sep 24, 2007 2:37 pm

Can you check your Tools - Options - General and see what you have checked or unchecked on the Ghosted Folder Options? Can you post a screenshot of that?

Tom.Wells
Posts: 65
Joined: Tue Sep 21, 2004 10:35 am

Post by Tom.Wells » Mon Sep 24, 2007 3:00 pm

I called them ghosted cause that's the label on the options page, "Show non-version-controlled files ghosted in file list". Here's the environment information.

Client Information
Vault Client Version: 3.5.1.4786
.Net Framework Version: 1.1.4322.2407
Operating System: Microsoft Windows XP Professional
Service Pack: 2.0
OS Version: 5.1.2600
Total Physical Memory: 2 GB
Time Zone: (GMT-06:00) Central Time (US & Canada)

Server Information
Vault Server Version: 3.5.1.4786
.Net Framework Version: 1.1.4322.2032
Operating System: Microsoft(R) Windows(R) Server 2003, Standard Edition
Service Pack: 0.0
OS Version: 5.2.3790
Timezone: (GMT-06:00) Central Time (US & Canada)
SQL Version: Microsoft SQL Server 2000 - 8.00.2187 (Intel X86)
Mar 9 2006 11:38:51
Copyright (c) 1988-2003 Microsoft Corporation
Enterprise Edition on Windows NT 5.2 (Build 3790: Service Pack 1)

License Information
3 serial number(s):
1 of 3: 25 users, permanent
2 of 3: 25 users, permanent
3 of 3: 25 users, permanent

Tom.Wells
Posts: 65
Joined: Tue Sep 21, 2004 10:35 am

Post by Tom.Wells » Mon Sep 24, 2007 3:03 pm

Screen shot attached
Attachments
Vault.jpg
Vault.jpg (43.71 KiB) Viewed 6803 times

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Mon Sep 24, 2007 3:56 pm

Thanks. Next, can you show a screenshot of the folder in Vault that should have Ghosted Files, but doesn't, and then show a screenshot of that same folder on disk?

We hadn't seen this before, but will try to reproduce it. Can you install the sp1 of the .NET framework on your server and see if that helps?

Tom.Wells
Posts: 65
Joined: Tue Sep 21, 2004 10:35 am

Post by Tom.Wells » Tue Sep 25, 2007 7:27 am

Nevermind. It's my fault. I've been working on a project for months. Several days ago I moved the working folder to a new location then did a Get Latest Version. I wanted to see if the project would still open properly. Sometimes we miss files and don't get them put in Vault. Then yesterday I went looking in Vault and couldn't see the shadowed files I was used to seeing. I didn't connect to what I had done a couple of days before. I tried putting one of them back and Vault immediately saw it. Embarrassing. Thanks for you time.

Locked