error trying to go to http://localhost/dragnet/

If you are having a problem using Dragnet, post a message here.

Moderator: SourceGear

Posts: 7
Joined: Wed Oct 04, 2006 7:13 am
Location: NJ
PostPosted: Wed Oct 04, 2006 7:35 am
Hi folks. We've installed a copy of DragNet for eval purposes. I edited the web.config and set logging from Quiet to Debug. No log file created.

When I try to go to http://localhost/dragnet/, I get:

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


A name was started with an invalid character. Error processing resource 'http://localhost/dragnet/'. Line 1, Position 2

<%@ Register TagPrefix="uc1" TagName="ProjectNavBar" Src="ProjectNavBar.ascx" %>

Any help is greatly appreciated! Thanks!

- Tara

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Wed Oct 04, 2006 11:17 am
See if the suggestions in this link help:
Linda Bauer
Technical Support Manager

Posts: 7
Joined: Wed Oct 04, 2006 7:13 am
Location: NJ
PostPosted: Wed Oct 04, 2006 1:52 pm
I got a little further, I think. I did aspnet_regiis to reinstall the IIS stuff, and that got aspx in there as a recognized extension. After that, I'd get the standard "404 page not found" error.

I poked around on TechNet IIS 6 troubleshooting pages, and noticed that IIS 6 defaults to prohibiting all Web Service Extensions. That didn't seem right to me, and I tried allowing the "Web Service Extension - ASP.NET v2.0.50727" which points to the aspnet_isapi.dll. THAT gave me an uglier error (see below), so I'm not sure what to try next. Thanks!

When I tried to connect to DragNet after that, I got:

"Server Error in '/Dragnet' Application.

is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. "

Posts: 3584
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Thu Oct 05, 2006 8:51 am
There must still be some kind of IIS configuration issue.

Assuming you've installed IIS and the supporting Application Data Server files, report back any configuration differences from this Setup Link - Installing Vault Server on Windows 2003 Server

If you ran aspnet_regiis.exe *AFTER* you installed Dragnet, then Dragnet will be missing some settings. Uninstall and reinstall Dragnet with IIS and ASP.Net configured so the missing pieces are added to the Dragnet installation.
Jeff Clausius

Return to Support (Dragnet)

Who is online

Users browsing this forum: No registered users and 1 guest