Integrating Vault & Dragnet w/o Anon Access

This forum is now locked, since gold support is no longer offered.

Moderator: SourceGear

Locked
Tony
Posts: 28
Joined: Wed Apr 13, 2005 6:18 am
Location: Pennsylvania
Contact:

Integrating Vault & Dragnet w/o Anon Access

Post by Tony » Wed Oct 05, 2005 1:42 pm

We have a single server running Vault and Dragnet. The Dragnet website (in fact, all websites other than Vault) requires Windows Integrated security and no anonomous access. The only reason Vault doesn't require it is that the client can't get to the webservice. It would be nice if the Vault client would impersonate the identity of the currently logged-in user to access it's web service. But that's not really my problem right now. :)

When we try to link Vault to Dragnet, Vault checkins complain that they can't find/access the Dragnet server.

Is Vault incapable of accessing a Dragnet website that is configured to disallow anonomous access and/or require WI authentication?

Tony

Tony
Posts: 28
Joined: Wed Apr 13, 2005 6:18 am
Location: Pennsylvania
Contact:

?

Post by Tony » Thu Oct 06, 2005 8:55 am

Has anyone had a chance to look into this at all yet?

jclausius
Posts: 3617
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Post by jclausius » Thu Oct 06, 2005 9:27 am

Tony wrote:It would be nice if the Vault client would impersonate the identity of the currently logged-in user to access it's web service.
The Vault client does send the currently logged on user's Windows Network credentials, and should support non-anon access.

Have you seen something different? I haven't tried this in a while (Vault 2.0.x), but let me double check that this is still the case.
Tony wrote:Is Vault incapable of accessing a Dragnet website that is configured to disallow anonomous access and/or require WI authentication?
What problems are you seeing when you try to access the Dragnet Web Service? What modifications did you make to Dragnet's Web Service? To which file?

When the Vault client contacts the Dragnet webservice, it also sends the Windows Network credentials of the currently logged on user. I did notice the Vault client is not sending those credentials when going through a proxy, but if you go straight to the Dragnet Web Service app, the Vault client is sending the Windows user's credentials.
Jeff Clausius
SourceGear

jclausius
Posts: 3617
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Post by jclausius » Thu Oct 06, 2005 10:19 am

I see the problem now. Dragnet's ASP.Net configuration only allows for Forms authentication. Windows Authentication is not supported.

That would explain the problems you're seeing from the Vault client.

I've added a feature request which would allow Windows Auth for Dragnett.
Jeff Clausius
SourceGear

Tony
Posts: 28
Joined: Wed Apr 13, 2005 6:18 am
Location: Pennsylvania
Contact:

What time frame are we talking about?

Post by Tony » Thu Oct 06, 2005 10:50 am

Thanks for your investigation and follow-up. Can you give me an idea of what time-frame we are talking about here? Hours, days, weeks, months? The whole reason we bought Dragnet was because of the integration it had with Dragnet. Without that, it lacks importnat core functionality for our development processes. Is there a work-around for the time being?

Tony

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Oct 06, 2005 12:53 pm

Dragnet does integrate with Vault. However, the Dragnet website currently must be configured to use anonymous access for users to see Dragnet information in the Vault Client.

We have logged a feature request to accomodate the configuration you have described. We don't have a timeframe just yet for our next release. In the meantime, the only workaround would be to allow anonymous access.
Linda Bauer
SourceGear
Technical Support Manager

Tony
Posts: 28
Joined: Wed Apr 13, 2005 6:18 am
Location: Pennsylvania
Contact:

Post by Tony » Thu Oct 06, 2005 12:59 pm

lbauer wrote:Dragnet does integrate with Vault.
You are correct, and it was inappropriate/inadvertant that I suggested otherwise. I guess my point is that a well secured and Windows integrated web site/server doesn't allow anonomous access and that it would be nice if the Dragnet product could be enhanced to accomodate this standard architecture.

Thanks for the feedback. I didn't mean to imply a lack of functionality.

Locked