System.BadImageFormatException: is not a valid Win32 applica

This forum is now locked, since gold support is no longer offered.

Moderator: SourceGear


Posts: 1
Joined: Tue Jun 13, 2006 4:40 am
PostPosted: Tue Jun 13, 2006 5:04 am
I've just installed Dragnet for the first time.

SQL 2005 SE, Windows 2003 Standard x64 edition, ASP.Net 2.0.50727 (64 bit)

The installation went smoothly but I get a rather nasty

System.BadImageFormatException: is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
stack trace :

[BadImageFormatException: is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)]
System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +495
System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +192
System.Reflection.Assembly.Load(String assemblyString) +42
System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +182

[ConfigurationErrorsException: is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)]
System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +1259
System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +388
System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +145
System.Web.Configuration.AssemblyInfo.get_AssemblyInternal() +30
System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +227
System.Web.Compilation.BuildProvidersCompiler..ctor(VirtualPath configPath, Boolean supportLocalization, String outputAssemblyName) +76
System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp) +323
System.Web.Compilation.BuildManager.CompileGlobalAsax() +64
System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +785

[HttpException (0x80004005): is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)]
System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() +76
System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +1168
System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) +906

[HttpException (0x80004005): is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +709
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +317
System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +595


Help! I get the feeling I need to switch to 32 bit mode for the .net 2.0

Thx

Simon

Posts: 490
Joined: Wed Jan 14, 2004 10:22 am
Location: SourceGear
PostPosted: Tue Jun 13, 2006 8:58 am
Dragnet hasn't been thoroughly tested on Windows 64 and isn't officially supported on Windows 64 yet.

Dragnet is a "32-bit" web service, and I believe if you want to try to get Dragnet to work on 64-bit Windows, IIS must be running in 32-bit mode. See the following Microsoft KB articles:

http://technet2.microsoft.com/WindowsSe ... x?mfr=true

http://support.microsoft.com/?id=894435
Mary Jo Skrobul
SourceGear

Return to Gold Support (Dragnet) -- Read-only

Who is online

Users browsing this forum: No registered users and 1 guest