NullReferenceException on OpenItems.aspx

This forum is now locked, since gold support is no longer offered.

Moderator: SourceGear


Posts: 30
Joined: Sat Jan 15, 2005 1:21 pm
Location: Portland, OR
PostPosted: Fri May 25, 2007 11:54 am
Greetings,

We're running dragnet 1.0.7.1379. When I go to the second tab on OpenItems.aspx for a particular project:

Dragnet/OpenItems.aspx?pid=102&selectedtab=2

I get sent to the "reset login" page. The event log has the attached message. It only happens on one project, not others, so must be a record that's screwy.

Can you help?

Ken

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 5/25/2007 10:41:32 AM
Event time (UTC): 5/25/2007 5:41:32 PM
Event ID: ed799733da67401294aa8c2fb174525b
Event sequence: 16
Event occurrence: 5
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/Root/Dragnet-7-128245884138341250
Trust level: Full
Application Virtual Path: /Dragnet
Application Path: C:\Inetpub\wwwroot\Dragnet\
Machine name: PINKMARTINI

Process information:
Process ID: 2988
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: NullReferenceException
Exception message: Object reference not set to an instance of an object.

Request information:
Request URL:
Request path:
User host address:
User:
Is authenticated: False
Authentication Type:
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 1
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at System.Web.Security.FormsAuthentication.SignOut()
at MantisServiceLib.Helpers.DeleteSession(HttpSessionState hss)
at Mantis.Global.Session_End(Object sender, EventArgs e)


Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Posts: 8427
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue May 29, 2007 10:40 am
On the setup pages, is there any chance you deleted some of the default items for statuses and such things?

Can you log into that one project as Admin?

Posts: 30
Joined: Sat Jan 15, 2005 1:21 pm
Location: Portland, OR
PostPosted: Tue May 29, 2007 11:09 am
Hi Beth,

Oh yes, I'm sure I've mucked around with default statuses and such. We've used this for almost 3 years now and it's been running pretty well. Oddly, I can look at that second tab for all other projects but that one, and they all use the default database items such as status.

I did just log in as Admin, poked around, all seems fine, but the same behavior for the second tab - NullReferenceException, even for that user. I'm sure there's just an errant record for that project. I'd be happy to zip up and send you our database on a secured channel.

ken

Posts: 8427
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue May 29, 2007 12:43 pm
If you can, just send an email to support at sourcegear.com (attn: Beth) with a link to this post and we'll take this offline.

Return to Gold Support (Dragnet) -- Read-only

Who is online

Users browsing this forum: No registered users and 1 guest