Unable to use Obliterate

If you are having a problem using Fortress, post a message here.

Moderator: SourceGear


Posts: 30
Joined: Tue Aug 15, 2006 6:17 pm
PostPosted: Tue Nov 04, 2008 10:46 am
Whenever I try to use the obliterate function I'm getting the following error message.

An error occurred processing the request:

Unable to Obliterate item: $/_CBTest

All branches of an item must be obliterated before the item itself can be obliterated. It is possible that some of the branched items have been deleted, but not obliterated. You must obliterate all branches before you can obliterate this item. This item has branches at:


Unfortunately, the list of "branches" is completely empty. I don't see why it doesn't think it can obliterate this folder. Also, note that we did just upgrade from Vault 4.1.2 to Fortress but I don't know if this is related at all.

Anyone have any thoughts on this?

Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
PostPosted: Tue Nov 04, 2008 11:35 am
The problem here is that the branches are deleted but not obliterated. You're right. This is a particularly unhelpful error message.

This error message is not Fortress-specific.
Subscribe to the Fortress/Vault blog

Posts: 30
Joined: Tue Aug 15, 2006 6:17 pm
PostPosted: Tue Nov 04, 2008 12:47 pm
Is there any way I can find what those branch "links" are?

Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
PostPosted: Tue Nov 04, 2008 1:13 pm
Unfortunately, the easiest way is to undelete the folder, and do a Show History for Branch operations.
Subscribe to the Fortress/Vault blog

Posts: 12
Joined: Fri Sep 09, 2005 7:52 am
PostPosted: Tue Nov 15, 2011 10:34 am
Where do I "undelete" a folder?

I too am getting the message:

Unable to Obliterate item: $/soc/ifix_50/Pic

All branches of an item must be obliterated before the item itself can be obliterated. It is possible that some of the branched items have been deleted, but not obliterated. You must obliterate all branches before you can obliterate this item. This item has branches at: (nothing specified here...)

There is also nothing listed in the pending change set. I do not see where to undelete a folder...

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue Nov 15, 2011 11:44 am
In your Vault GUI client, right-click the parent folder of the item that was deleted, then look in the deleted items tab. You will see what items are deleted, and you can restore any from there.

A good way to ensure you obliterate branches properly is to first run a history query on just the branch actions (there's a tab in the delete dialog to just select Branch). Then you see what items were created from where.
Beth Kieler
SourceGear Technical Support

Return to Support (Fortress)

Who is online

Users browsing this forum: No registered users and 7 guests

cron