CCNET Source Get Fail

If you are having a problem using Fortress, post a message here.

Moderator: SourceGear

jclausius
Posts: 3617
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: CCNET Source Get Fail

Post by jclausius » Mon May 10, 2010 8:24 pm

Note, an updated CCNET 1.5 can be found on our download site. We tested it against CC.NET 1.5 Build 7256.1, but believe it will also work for the 1.5 release candidate.
Jeff Clausius
SourceGear

atulmistry
Posts: 1
Joined: Fri Nov 05, 2010 6:31 am

Re: CCNET Source Get Fail

Post by atulmistry » Fri Nov 05, 2010 1:39 pm

has a fix for this been published?

i'm getting the same error in ccnet:

2010-11-05 15:30:04,421 [DB Test:WARN] Source control failure (GetModifications): Field not found: 'ThoughtWorks.CruiseControl.Core.Modification.ChangeNumber'.

I'm using ccnet 1.5 and Vault 4.1.4.

I tired using ccnet 1.4.x with the Vault 4.1.4 ccnet plugin but that crashes ccnet. when i just use the vault plugin provided with ccnet, i get:

System.Exception: Could not map path to anything useful: Source

if i run the vault command manually from the command line, it works fine.

Thanks,

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: CCNET Source Get Fail

Post by lbauer » Tue Nov 09, 2010 2:49 pm

The update for CCNET 1.5 is only available for Vault 5.x/Fortress 2.x. Vault 4.x was released in November, 2008, and CCNET 1.5 was released in May of 2010. We try to make sure we keep our latest releases compatible with new technologies.
Linda Bauer
SourceGear
Technical Support Manager

Post Reply