Files Read/Write on file modify

If you are having a problem using Fortress, post a message here.

Moderator: SourceGear


Posts: 7
Joined: Thu Aug 20, 2009 11:41 am
PostPosted: Fri Aug 05, 2011 9:53 am
I'm been using Visual Studio 2008 with Fortress 2.0.3 for quite some time. When we moved from Vault to Fortress I set VS to use the Enhanced plug-in. I guess it didn't take (must not have redone the binding). Anyway, all this time I had it (somehow) set up where when I modify a file in VS, it would auto check it out and make the file read/write. Yesterday I unbinded the solution and rebinded it using the enhanced plug-in. But now I have to right click on the file, check it out which makes it read/write.
I'm probably overlooking the obvious, but isn't there a way (setting) to make the file auto-check out when you modify the file in Visual Studio?

Thanks

Posts: 7
Joined: Thu Aug 20, 2009 11:41 am
PostPosted: Fri Aug 05, 2011 9:59 am
Additional...In VS/Tools/Options/Source Control/Integration Options...'Automatically Check Out' is selected for the 'When check out is required, on edit:'

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri Aug 05, 2011 1:19 pm
Try the following steps for rebinding and let me know if the behavior changes.

1) Go to File - Source Control - Change Source Control or Fortress Source Control - Change Fortress Bindings depending on which client you are using.
2) Select all lines in the window that opens and click Unbind.
3) Click OK and Save All.
4) Go to File -Source Control - Change Source Control or File - Fortress Source Control - Change Fortress Bindings.
5) Select one line that is not the .sln file and click Bind.
6) When the binding window opens, select the folder that element resides in and click OK.
7) Check that the status for that line is Valid.
8_) Repeat on each line. Bind the line for the .sln file last. When all are Valid, click OK.
9) Check in the changes to the .sln and project files.

Also, check that you are not working "offline". There is a check box at the bottom of the Change Bindings dialog that needs to be checked to be "online."
Beth Kieler
SourceGear Technical Support

Posts: 7
Joined: Thu Aug 20, 2009 11:41 am
PostPosted: Fri Aug 05, 2011 3:07 pm
Thanks for the information.
I tried the steps you mentioned exactly. There are only two items (and have always only been two items) that were bound..the solution(sln) and the project(csproj) file. I unbound both and when rebinding, I only rebound the project file and not the solution. Then I rebound the solution. I also made sure the 'Online' checkbox was checked.
After rebinding I check in the project and solution files, shut down VS and restarted it and opened the solution. I then made a change to a source file in VS but the same behavior occurred...the file was not automatically checked out.
The status was Valid after rebinding.
In #8 you indicate there should be more items to bind?

Posts: 7
Joined: Thu Aug 20, 2009 11:41 am
PostPosted: Fri Aug 05, 2011 3:25 pm
Here's a little history...
I've been the only person using the repository in question. I'm using VS2008. When our Vault server was upgraded to fortress 2.0.3 we were instructed to attach to the new server using the Enhanced plug-in. I did it but you apparently have to rebind to make it take.
I only hit the repository from one machine. The other day I wanted to set up a laptop to use remotely. I hit the repository from the laptop. When I got back on my main machine this behavior began. I looked and saw it was set to use the 'Classic Client'. I thought this was the issue. So, I unbound/rebound the solution using the Enhanced plug-in. The behavior still continues.
I've checked on the laptop and it looks normal. No files checked out. It won't let me check anything in which is what I expect.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri Aug 05, 2011 4:12 pm
I'd like to take a closer look at this offline. First, can you upgrade your Fortress client to 2.0.4 (http://download-us.sourcegear.com/Fortr ... _18845.msi)?

Then could you send an email to support at sourcegear.com (attn: Beth) with a link to this forum thread?
Beth Kieler
SourceGear Technical Support

Posts: 7
Joined: Thu Aug 20, 2009 11:41 am
PostPosted: Mon Aug 08, 2011 7:33 am
I downloaded and installed 2.0.4. It installed properly. I then opened Visual Studio, opened a *.cs source file and made a modification. I noticed that it didn't check out. I clicked the Save button and it opened a Save dialog box prompting me to save a another file name. I then followed your steps in the previous post. The same thing. It won't auto-check out when a file is modified.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon Aug 08, 2011 8:10 am
I've received your email and will be replying shortly.

HS: 223671
Beth Kieler
SourceGear Technical Support

Return to Support (Fortress)

Who is online

Users browsing this forum: No registered users and 6 guests

cron