login failure to Fortress server using Fortress client

If you are having a problem using Fortress, post a message here.

Moderator: SourceGear


Posts: 12
Joined: Fri Sep 09, 2005 7:52 am
PostPosted: Thu Mar 28, 2013 11:45 am
I am receiving the following error message when attempting to connect to Fortress via the Fortress client:

Unable to connect to http://webserver:8080/VaultService. No server was found at the specified URL. Please verify your network settings using the Options dialog under the Tools menu in the Vault GUI Client. Web Exception: The request failed with HTTP status 401: Unauthorized.

The server address is correct. The login is correct. Both verified by using Firefox and navigating to "http://webserver:8080/VaultService/VaultWeb/Default.aspx". I restarted IIS on the target server, but no change. Please help as we cannot checkin or checkout our applications.

Client version is: 1.0.4 (15848)
Server version is: 1.0.4.15848

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Thu Mar 28, 2013 2:15 pm
So you were able to connect before, but now you're getting this error?

Has something changed on the Vault Server machine or in IIS?

Did you recently do any Windows Updates on the Vault Server machine?

What operating system is the Vault Server on?
Linda Bauer
SourceGear
Technical Support Manager

Posts: 12
Joined: Fri Sep 09, 2005 7:52 am
PostPosted: Thu Mar 28, 2013 4:10 pm
lbauer wrote:So you were able to connect before, but now you're getting this error?

Has something changed on the Vault Server machine or in IIS?

Did you recently do any Windows Updates on the Vault Server machine?

What operating system is the Vault Server on?


Yes. We were able to connect until very recently. I do not know of any patches applied to the server. It is running on a Windows2003 SP2 box. Currently we have no PDC in our network, only a BDC.

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Fri Mar 29, 2013 7:30 am
Verify that Anonymous Access is enabled for the Vault Service website in IIS. Open IIS Manager, and right-click on VaultService. Select Properties->Directory Security. Click Edit in the Authentication and access control section. Then check "Enable anonymous access."
Attachments
IIS6_AnonAccess.jpg
IIS Anonymous Access
IIS6_AnonAccess.jpg (87.17 KiB) Viewed 14768 times
Linda Bauer
SourceGear
Technical Support Manager

Posts: 12
Joined: Fri Sep 09, 2005 7:52 am
PostPosted: Fri Mar 29, 2013 10:57 am
Enable anonymous access is checked. See screenshot. I also attached output from the IIS diagnostic tool on the server.
Attachments
FORTESS LOGIN ISSUE 3-29-2013 12-49-16 PM.png
FORTESS LOGIN ISSUE 3-29-2013 12-49-16 PM.png (25.21 KiB) Viewed 14762 times
FORTRESS LOGIN ISSUE(DIAG) 3-29-2013 12-51-50 PM.png
FORTRESS LOGIN ISSUE(DIAG) 3-29-2013 12-51-50 PM.png (19.67 KiB) Viewed 14762 times

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Fri Mar 29, 2013 3:00 pm
You have Anonymous Access enabled, but based on the Microsoft Diagnostics errors, the IUSR_<servername> account isn't able to login because of a password error. Could the password have expired or did someone make a change?

The IUSR account is created when you install IIS. It's a built-in account for anonymous access to Internet Information Services. So there's some type of IIS configuration issue here.

Here is a link that may help:
http://support.microsoft.com/kb/909887
Linda Bauer
SourceGear
Technical Support Manager

Return to Support (Fortress)

Who is online

Users browsing this forum: No registered users and 4 guests

cron