Exception connecting to server

Post your questions regarding using the Vault and Fortress API in your programs.

Moderator: SourceGear

Post Reply
smartbear
Posts: 38
Joined: Thu Jan 24, 2008 10:13 am
Contact:

Exception connecting to server

Post by smartbear » Wed Feb 25, 2009 4:11 pm

Can you take a look at this error? We're using the 4.1.4 Java client API release, and a customer is having problems using our integration to connect to his server. The client never appears to finish connecting, and gets these exceptions:

2/25/2009 1:25:52 PM <crypto>: Failed encryption. [System.ArgumentOutOfRangeException: Non-negative number required.
Parameter name: dstOffset
at system.Buffer.BlockCopy(Buffer.java:51)
at Mono.Security.Cryptography.PKCS1.I2OSP(Unknown Source)
at Mono.Security.Cryptography.PKCS1.Encrypt_v15(Unknown Source)
at system.Security.Cryptography.RSAPKCS1KeyExchangeFormatter.CreateKeyExchange(Unknown Source)
at system.Security.Cryptography.RSACryptoServiceProvider.Encrypt(Unknown Source)
at VaultLib.VaultUserCrypt.EncryptPassword(Unknown Source)
at VaultClientNetLib.VaultConnection.Login(Unknown Source)

I've attached the Vault client API log file.

Thanks,
Eric

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Re: Exception connecting to server

Post by jeremy_sg » Thu Feb 26, 2009 9:09 am

Eric,

I don't see the log file. Could you have the user check his Event Viewer to see if anything is logged there? I've never seen this error before, for what that's worth. Can the user have another person log on on his machine with their Vault credentials? Can he log on with the Java CLC from another computer?
Subscribe to the Fortress/Vault blog

smartbear
Posts: 38
Joined: Thu Jan 24, 2008 10:13 am
Contact:

Re: Exception connecting to server

Post by smartbear » Thu Feb 26, 2009 1:56 pm

Oops. Got a "The extension log is not allowed" error attaching that file. Here it is. I'll check with the user about vault.exe
Attachments
ccollab_vault.txt
(80.61 KiB) Downloaded 349 times

jeremy_sg
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
Contact:

Re: Exception connecting to server

Post by jeremy_sg » Thu Feb 26, 2009 2:07 pm

I see the issue more clearly now. The Java crypto API is unreliable for some unknown reason. We get these exceptions and log the fact that we got them, and then try to encrypt the string again. You can see the log message: 2/25/2009 "<crypto>: Took N tries to encrypt the password" in the log file. This message is logged when the string is finally encrypted. I can also see from the log that it did get connected (At least it called the server to ask for an updated tree structure at 1:21:15). The only true error I see in the log file is: "UnknownHostException" at 1:24:20.
Subscribe to the Fortress/Vault blog

Post Reply