DiffMerge doesn't install on Ubuntu 18.04

Support for our DiffMerge utility.

Moderator: SourceGear

Post Reply
starrtennis
Posts: 1
Joined: Tue Jun 16, 2020 1:14 pm

DiffMerge doesn't install on Ubuntu 18.04

Post by starrtennis » Tue Jun 16, 2020 1:30 pm

Hi. I have Ubuntu 18.04 (Bionic) Kernel 5.3.0 linux and I downloaded the 64 bit Ubuntu .deb install file for installation of diffmerge to use with Unity on my system. The download appears to finish, the loading bar quickly completes, as opened in the Ubuntu Software, but then it does not indicate that the install has completed successfully and it reverts to the screen state indicating it is yet to be installed.

When I manually dpkg the .deb file, there are some dependencies, most of which I can resolve, but one which I cannot: libpng12-0. It appears Ubuntu has moved on and updated libpng (to 16 from 12, here: https://packages.ubuntu.com/search?suit ... chon=names) but, alas, this is only for 19.10 and I don't know if it would work on 18.04, let alone at all if the dependency from DiffMerge is for an outdated package.

Halp?

jclausius
Posts: 3655
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: DiffMerge doesn't install on Ubuntu 18.04

Post by jclausius » Wed Jun 17, 2020 12:59 pm

Can you try the DiffMerge beta posted here to see if that helps - viewtopic.php?f=33&t=23084
starrtennis wrote:
Tue Jun 16, 2020 1:30 pm
Hi. I have Ubuntu 18.04 (Bionic) Kernel 5.3.0 linux and I downloaded the 64 bit Ubuntu .deb install file for installation of diffmerge to use with Unity on my system. The download appears to finish, the loading bar quickly completes, as opened in the Ubuntu Software, but then it does not indicate that the install has completed successfully and it reverts to the screen state indicating it is yet to be installed.

When I manually dpkg the .deb file, there are some dependencies, most of which I can resolve, but one which I cannot: libpng12-0. It appears Ubuntu has moved on and updated libpng (to 16 from 12, here: https://packages.ubuntu.com/search?suit ... chon=names) but, alas, this is only for 19.10 and I don't know if it would work on 18.04, let alone at all if the dependency from DiffMerge is for an outdated package.

Halp?
Jeff Clausius
SourceGear

chalancito
Posts: 1
Joined: Mon Aug 24, 2020 1:16 am

Re: DiffMerge doesn't install on Ubuntu 18.04

Post by chalancito » Mon Aug 24, 2020 1:26 am

Well, really I have a LUBUNTU 20.04 OS and also had a dependencies issue trying to install diffmerge_4.2.0.697.stable_amd64
I tried the beta release diffmerge_4.2.1.817.beta_amd64 and is already installed and working fine in my preliminary tests.
Thanks for that!
(I also have a LUBUNTU 18.04 installation, i will let you know my experiences "there".)

Chalancito

Post Reply