DiffMerge takes a long time to save large files

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 4
Joined: Fri Aug 13, 2010 1:52 pm
PostPosted: Fri Aug 13, 2010 2:05 pm
I work with some legacy code that is over 20 years old.. Some of the code files our team works with exceeds 64K in lenth..

For example.. one file contains 140458 CRLF and contains 6081576 bytes..

When loading, and merging changes, this is rapid fast which is why I like this tool so much :)

When saving, however, it can take up to 5 minutes to save.. Smaller files usually save rapid fast, so this seems to only be an issue for some really large files.. Is there any work around that I could apply?

Thanks

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Mon Aug 16, 2010 8:23 am
Yes, we have some performance problems with extremely large files.
Sorry.

As for why saving is slow, the only thing I can think of is that we have
to convert the in-memory version of the file from UNICODE wide-chars
back into the original encoding before we write it to disk. This could
take a little time, but if this is the problem I'm not sure why you're not
seeing it when you load the files (because we are converting them from
the native encoding into UNICODE before we start drawing them on
the screen).

Is the problem when just saving or when saving and exiting? I ask
because there are some performance issues freeing all of our memory
at the end that can cause a delay before we actually exit.

jeff

Posts: 4
Joined: Fri Aug 13, 2010 1:52 pm
PostPosted: Wed Aug 18, 2010 10:36 am
Hi Jeff,

Apologies for the late reply.

The business machine I'm using is a new one (as of Jan) from my company. It's not the fastest in the world, but its pretty good. Plenty of memory.

The file I mentioned takes about 3 seconds to load and it took over 10 minutes to save.. *wow*. I only copied over one single change. Both are on a shared (but local) drive letter.. Control-S in our code IDE (Foxpro) saves it in a fraction of a second..

We do use encryption on our drive.. so I decrypted the source folder and tried again.. its still taking a long time..
We also use anti-virus of course and are running XP.

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Wed Aug 18, 2010 12:00 pm
I'll have to take a look and see what's going on. After
your note last week I just happened to load a very large
file myself and notice the same thing. I haven't had a
chance to see what it is, yet.

Thanks for the report and I'll keep you posted.
jeff

item:15525

Posts: 4
Joined: Fri Aug 13, 2010 1:52 pm
PostPosted: Wed Aug 18, 2010 1:16 pm
Thank you Jeff!

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 4 guests