files are identical or equivalent under the current rule set

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 1
Joined: Mon Jun 17, 2013 10:29 am
PostPosted: Mon Jun 17, 2013 10:43 am
Hi, I get that "files are identical..." message when I double-click in Folder Diff on files that are shown in red as different.

I'm using the default Ruleset, Detail Level = Lines only, and in Equivalence Mode I have "Exact Match or Simple" and Ignore Line Termination, Ignore Whitespace, and Treat TABS as Whitespace.

I need them to not show up in the Folder Diff window. What should I do?

Thanks,
Jackie

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Tue Jun 18, 2013 6:13 am
Try setting "Exact Match or Ruleset" and turn on "Enable Default Ruleset"
on the "Equivalence Mode" page of the Options dialog.

You should then see the "nearly equal" files as marked "equivalent"
in the folder window.

Let us know if that doesn't take care of it.
jeff

Posts: 3
Joined: Wed Aug 21, 2013 2:29 am
PostPosted: Wed Aug 21, 2013 5:46 am
I have the same problem.

I followed your instructions:

jeffhostetler wrote:Try setting "Exact Match or Ruleset" and turn on "Enable Default Ruleset"
on the "Equivalence Mode" page of the Options dialog.

You should then see the "nearly equal" files as marked "equivalent"
in the folder window.
[...]


The problem ist that this configuration only works one single time under Mac OS X.
Opening the folder diff again brings up all the equal files again. And when I double click one file for diff I get the message that files are identically under the current ruleset. When I go back to preferences and diable the option "Enable Default Ruleset" and click "OK", go back to the options again and enable "Enable Default Ruleset" it works again for 1 time.

Any suggestions?

Best regards
Torsten

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Thu Aug 22, 2013 7:42 am
I'm not able to reproduce the problem here.
Could you email a few files and I'll try to figure it out.

Please zip up:
[*] "~/Library/Preferences/SourceGear DiffMerge Preferences"
[*] the contents of the Support Dialog (available from the About Dialog)
[*] one pair of files that have the problem.

and send them to jeffh @ sourcegear.com

thanks

Posts: 3
Joined: Wed Aug 21, 2013 2:29 am
PostPosted: Fri Aug 23, 2013 1:46 pm
Thanks! I will send you the mail immediately.

Best regards
Torsten

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Mon Aug 26, 2013 10:13 am
A quick note for the forum. With the files I received from Tomcraft
I have reproduced the problem. I have a fix for it in my dev tree
which will be in 4.2. The problem was that subsequent invocations
did not respect the "allow default ruleset" setting (the ctor failed to
load that field from the preferences).

W3104

Posts: 3
Joined: Wed Aug 21, 2013 2:29 am
PostPosted: Mon Aug 26, 2013 2:39 pm
Thank you for fixing this soon. :-)

Best regards
Torsten

Posts: 2
Joined: Tue Sep 17, 2013 4:15 pm
PostPosted: Tue Sep 17, 2013 4:53 pm
I too am having a similar problem - the files that are marked in red 'Not Equal' are equivalent when clicked. So I have two large directories with hundreds of sub-files and I'm trying to find the dozen or so that are different...not going to happen! They are there, but buried amongst the files with no real errors. I'd have to click on every single file to find them.

Is there any sort of workaround in the meantime? I've tried all the settings mentioned above. Folder Windows Equivalence Mode is Exact Match or Ruleset-based..., File Windows Rulesets are set to (under Equivalence Mode) Ignore/Strip..., Ignore/Fold..., Ignore/Strip...otherwise all is defaults.

Hope the upgrade is soon!

Thanks.

Posts: 2
Joined: Tue Sep 17, 2013 4:15 pm
PostPosted: Tue Sep 17, 2013 5:03 pm
I think it may have something to do with the new line being either CRLF (Windows) and LF (Unix/OSX). I'd figure that the option "Strip All Line Termination Characters" would catch that, but perhaps not?

As an experiment I used TextWrangler to look at a file that was near the top of the list for both directories - sure enough one used CRLF and the other used LF - so changed the first one to LF and they both subsequently disappeared from the compare window on refresh!

So, how does one set this to ignore CRLF/LF?

Thanks!

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Thu Sep 19, 2013 1:29 pm
The folder window should be able to ignore differences
in EOLs and mark them as equivalent (which you can then
hide like equal files).

With the bug, the settings in the "default" ruleset aren't
being loaded by the folder window, so changing it won't
help right now.

Would it be possible/practical to create a new named
ruleset with all of suffixes for the files in your 2 trees?
And then make sure that "strip/ignore eol" is turned on
in the equivalences page.

I'm hoping to have 4.2 out mid-October.

jeff

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 4 guests

cron