Deprecation notices (Mac 4.0.0 [intel] stable)

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 1
Joined: Wed Jul 24, 2013 11:40 am
PostPosted: Wed Jul 24, 2013 12:04 pm
No problem with functionality; just unexpected text appearing on stderr when running from command line.
Using the diffmerge.sh script the following deprecation messages are sent to stderr:
Code: Select all
2013-07-24 11:45:50.108 DiffMerge[29683:f07] -_continuousScroll is deprecated for NSScrollWheel. Please use -hasPreciseScrollingDeltas.
2013-07-24 11:45:50.111 DiffMerge[29683:f07] -deviceDeltaX is deprecated for NSScrollWheel. Please use -scrollingDeltaX.
2013-07-24 11:45:50.112 DiffMerge[29683:f07] -deviceDeltaY is deprecated for NSScrollWheel. Please use -scrollingDeltaY.

DiffMerge Version 4.0.0 (418:528963e10a) [intel] stable
System Version: OS X 10.8.4 (12E55)

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear
PostPosted: Wed Jul 24, 2013 3:37 pm
I've seen those too. Don't worry about them.

That's an issue with wxWidgets 2.9.4. They have
fixed it in 2.9.5 and I'm testing with it now for my 4.1
release due out in a few weeks.

thanks
jeff

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 1 guest