Empty Diff window when launching from TortoiseHg on MacOS

Support for our DiffMerge utility.

Moderator: SourceGear

Post Reply
Posts: 1
Joined: Fri Jan 10, 2014 3:26 am

Empty Diff window when launching from TortoiseHg on MacOS

Post by sam@seaturtle » Fri Jan 10, 2014 3:33 am

I'm using FogCreek's Kiln client version of TortoiseHg, and I've set up DiffMerge according to the instructions on your Diffmerge webiste at http://sourcegear.com/diffmerge/webhelp ... x_mac.html.

But when I try to Diff a file, the DiffMerge window opens, but the files have not been selected for diffing.

I've also tried using the path to the executable inside the .app package, but that hasn't worked either.

Any ideas?

Posts: 534
Joined: Tue Jun 05, 2007 11:37 am
Location: SourceGear

Re: Empty Diff window when launching from TortoiseHg on MacO

Post by jeffhostetler » Fri Jan 10, 2014 10:43 am

I'm not sure, but it sounds like TortoiseHG is not putting
the files to be compared on the command line.

To test this, let TortoiseHG start DiffMerge and then go
to the About Dialog and then click on Support. This should
raise a dialog with a bunch of info about the current session.

Near the top is a section with the command line arguments.
See if there are any file arguments in the list.

If not, you may need to tweak your HG config file and
tell it about the command line. I can't test this, but maybe
try adding:

opts.diffmerge = $parent $child

and see if you get the pathnames passwd into DiffMerge.


Post Reply