Keyboard accelerators mostly don't work on Mac

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 1
Joined: Tue Jan 13, 2015 4:29 pm
PostPosted: Tue Jan 13, 2015 4:39 pm
There seem to be a lot of focus issues on the Mac that keep keyboard accelerators from working. The Auto-Merge Results dialog always shows up with the Ok button highlighted, so I should just be able to hit return to select it but the focus is always somewhere else so it never works. I can't even tab to it like a normal Mac dialog.

The "Apply Change from *" buttons don't work unless I manually click inside the actual diff which is pretty useless. Also there's no "Jump to * conflict" shortcut.

It would also be nice if all those toolbar actions were in the menu bar. That might alleviate the focus issue but it would also allow mac users to rebind the shortcuts using the System Preferences.

Any chance these things could be fixed?

It would also be nice if it would automatically select the first conflict if there is one.

Thanks!

Posts: 8418
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Jan 14, 2015 5:35 pm
What Mac OS version do you have?

Are you using DiffMerge 4.2 or a different version?
Beth Kieler
SourceGear Technical Support

Posts: 4
Joined: Tue May 17, 2016 6:44 am
PostPosted: Tue May 17, 2016 6:46 am
I'm getting hit with the same frustrations. Particularly when I use diffmerge as my mergetool in git. When working through a large rebase with many conflicts I have to do a lot of mousing around which is very frustrating :arrow: .

I'm on Mac OS 10.11 and DiffMerge 4.2.1

Posts: 8418
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue May 17, 2016 4:02 pm
bdarfler: Does it act the same way when using it separately from Git? Launch just DiffMerge and do a File Diff.
Beth Kieler
SourceGear Technical Support

Posts: 4
Joined: Tue May 17, 2016 6:44 am
PostPosted: Wed May 18, 2016 1:33 pm
Beth,

I created a trivial manual merge setup with 3 copies of a file where I made different changes the same line in two of them, leaving the third one as the common ancestor.

In this case, I do not get the "Auto-Merge Results" dialog at all. I prefer not seeing the dialog but I cannot confirm or deny that the focus issue is resolved. Additionally, the "Apply Change *" and "Jump to *" keyboard shortcuts do work.

Posts: 8418
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed May 18, 2016 3:28 pm
One thing you could try is to go to System Preferences - Keyboard - Shortcuts and click the radio button 'All Controls.' That should help with tabbing around on some of the dialogs. Let me know if that helps.

Also, in Diff Merge, go to your Preferences and click on Messages. There you can turn off any of the dialogs listed.
Beth Kieler
SourceGear Technical Support

Posts: 4
Joined: Tue May 17, 2016 6:44 am
PostPosted: Thu May 19, 2016 8:32 am
Hi Beth,

I already have 'All Controls' enabled. Additionally I have turned off the Auto Merge Conflicts Message in DiffMerge settings in a hope that the Auto Merge Results Message will not show up but this has not worked.

Ben

Posts: 8418
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue Jul 26, 2016 3:25 pm
I've went through the keyboard shortcuts and can't find any failing ones. I have confirmed that the Auto-Merge Results comes up no matter which OS is used. I will log a bug on that one.

V: G5662
Beth Kieler
SourceGear Technical Support

Posts: 4
Joined: Tue May 17, 2016 6:44 am
PostPosted: Wed Jul 27, 2016 5:21 am
Thank you for following up on this!

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 1 guest