Support for libpng16

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 1
Joined: Tue Aug 29, 2017 3:50 pm
PostPosted: Mon Nov 27, 2017 12:55 pm
I'm using a version of debian that has libpng16-16 installed instead of libpng12. When I install the deb it complains:

diffmerge : Depends: libpng12-0 (>= 1.2.13-4) but it is not installable

If i try running it anyway i get:

diffmerge: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Can a new version be released that supports libpng16?

Thanks

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon Nov 27, 2017 4:02 pm
I will add a feature request for this so that the developers see it.

Unfortunately the only immediate solution I have is to download and install libpng12.

F: 19919/V: G9909
Beth Kieler
SourceGear Technical Support

Posts: 3565
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Fri Aug 17, 2018 11:35 am
I have a build of DiffMerge 4.2.1 that is a beta for Ubuntu 18.04 (64-bit).

I don't know if it will work on your version of Debian, but if you would like to try it out, and report back your findings, the Ubuntu package can be found at: https://drive.google.com/file/d/1sj_6QH ... sp=sharing
Jeff Clausius
SourceGear

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 5 guests

cron