VS 2019 Extension for Blazor Project - New Files Not Detected

If you are having a problem using Vault, post a message here.
Post Reply
mikecausi
Posts: 20
Joined: Wed Mar 03, 2010 12:48 pm

VS 2019 Extension for Blazor Project - New Files Not Detected

Post by mikecausi » Wed Nov 11, 2020 1:45 pm

Between the developers, when one person adds a file to the project, the others do not see it, from within Visual Studio 2019 when getting the latest version. This is not using the client but the extension in Visual Studio 2019.

However, if one person edits an existing file, it is properly detected by the other person's Visual Studio 2019. This is OK.

This is our first 2019 and Blazor project. We have used VS 2017 Extension with success.

Can you help us walk through some troubleshooting?

Thanks,
Mike

Tonya
Posts: 657
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: VS 2019 Extension for Blazor Project - New Files Not Detected

Post by Tonya » Wed Nov 11, 2020 2:47 pm

Hi Mike,

We have a few more questions for you to better understand the problem:

Is this project specific? Or does the newly added files not show up for others in different projects? If so, is the project type different (Blazor, etc)?

How is the end user adding the new files? Did you use Blazor projects when you were using VS 2017?

What version of Vault do you have installed?

Thanks,

Tonya

mikecausi
Posts: 20
Joined: Wed Mar 03, 2010 12:48 pm

Re: VS 2019 Extension for Blazor Project - New Files Not Detected

Post by mikecausi » Thu Nov 12, 2020 8:47 am

Hi Tonya,

Yes, after some more testing, the problem seems to be in Blazor projects in 2019. We tested an MVC 5 project in 2019 and was able to add files and have other users see the changes.

The user is adding the new files from the Visual Studio 2019 solution explorer.

We are running v10 on the client and server. We have also installed the latest Visual Studio extension.

Thanks,
Mike

Tonya
Posts: 657
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: VS 2019 Extension for Blazor Project - New Files Not Detected

Post by Tonya » Thu Nov 12, 2020 4:18 pm

Mike,

I wanted to let you know that we were able to reproduce the issue. Blazor Projects have project files that does not contain a list of files that are under source control so Vault doesn't currently know how to handle items not found in the project file. As files are added, Vault does not realize the files exist and they're there to do a GET. We are logging a bug for this to be resolved in Vault 11.

One of the developers assisting me with your issue, gave me a workaround until it can get resolved:

From within Visual Studio, the user can (without ever having to shut Visual Studio down):
Create a .bat or .cmd file that launches the CLC to do a GET on the solution or project's root folder found in the repository. Then hook up the batch command to Visual Studio's External Tools. This External Tool Entry can be invoked from the Visual Studio Tools menu (or create a toolbar button for the command)

If using Visual Studio 16.3 or later, Run the Visual Studio "Command Line" -> "Devleoper Command Prompt" to invoke a batch file outlined in the above step or type in the CLC command to to a GET on the solution or project level folder within the repository.

You do not have to shut down Visual Studio, after performing the Get from the command-line, the files should appear within Visual Studio. Also note, if you have the setting to STORE working folder state file information within the working folders themselves, those files will initially show up in Visual Studio. You will have to invoke "Exclude From Project" on the _sgvault directory, and then make sure on the prompt to not delete these files from the working folder.

Please let me know if you have any additional questions.

Thanks,

Tonya

Post Reply