Plugins page on Vault Admin

If you are having a problem using Vault, post a message here.
Post Reply
BigBrett
Posts: 217
Joined: Wed Feb 01, 2006 8:45 am

Plugins page on Vault Admin

Post by BigBrett » Tue Aug 31, 2021 12:27 am

For Source Code Control:
localhost is active for both VaultIndexService and VaultNotifyService
current host is inactive for both VaultService/VaultIndexService and VaultService/VaultNotifyService
Two older host names are inactive for the same two previous services

For Work Item Tracking:
localhost is active for VaultNotifyService
current host is inactive for VaultService/VaultNotifyService
Two older host names are inactive for the same previous service

Question 1: Should the current host be set as active for the relevant plugins ?

Question 2: Can the older host name entries be deleted ?

Regards,
Brett

BigBrett
Posts: 217
Joined: Wed Feb 01, 2006 8:45 am

Re: Plugins page on Vault Admin

Post by BigBrett » Tue Aug 31, 2021 7:01 am

Further to this, I have been looking at the Vault Server log files and see a few problems.

The service is restarting at random times between 1 minute and 2 days apart:

Code: Select all

----8/27/2021 8:40:11 AM     sgvaultsystem--()--	
	System Started
	Version 10.1.0.31128
	Cache Level = 1
	DataBase Buffer Size (KB) = 256
	LogFile Path = C:\Windows\Temp\sgvault
	Log Level = Quiet
	Archive Log = Weekly
	ReverseDNS Lookup = True
	Maximum HTTP Request Length = 102400
	Overwrite Log on Startup = False
	Session Timeout = 10080
	SGVault Working Directory = C:\Windows\Temp
	SGVault Server URL = http://kbserver2
	Identity = IIS APPPOOL\VaultAppPool 
.
.
----8/27/2021 9:21:32 AM     sgvaultsystem--()--	
	System Started
.
.
----8/30/2021 9:05:20 AM     sgvaultsystem--()--	
	System Started
----8/30/2021 9:11:26 AM     sgvaultsystem--()--	
	System Started
Also, starting yesterday, there are many plugin error messages as follows:

Code: Select all

----8/30/2021 10:12:42 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event Login.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:13:17 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:13:24 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event Login.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:19 AM    --()--	The Plugin at http://127.0.0.1/VaultIndexService/VaultIndexService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:19 AM    --()--	The Plugin at http://localhost/VaultShadowFolder/VaultShadowFolderService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:19 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:19 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:24 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:24 AM    --()--	The Plugin at http://localhost/VaultShadowFolder/VaultShadowFolderService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:24 AM    --()--	The Plugin at http://127.0.0.1/VaultIndexService/VaultIndexService.asmx was not called with Event Change Set.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:24 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:39 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:44 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:14:56 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:15:26 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event CheckOut List Change.  Exception: The request failed with HTTP status 404: Not Found. 
----8/30/2021 10:15:29 AM    --()--	The Plugin at http://127.0.0.1/VaultNotifyService/VaultNotifyService.asmx was not called with Event Logout.  Exception: The request failed with HTTP status 404: Not Found. 
Is there any easy way to fix this other than a reinstall of the Vault Server ?

Tonya
Posts: 718
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Plugins page on Vault Admin

Post by Tonya » Tue Aug 31, 2021 7:55 am

Hello,

In regards to your initial post, the old host names can be deleted. Is "Current Host" indicated as the Server URL under the plugins? And they are currently inactive? If so and your plugins are working correctly, they should not be enabled. Only one URL should be enabled for each service.

Your server restart issue will need to be further evaluated. Please send your Vault Server log to support@sourcegear.com.

What changes have you made to your environment that started the "404 Error"? Did you enable or disable any of the plugins? Your Vault Server log will help us try to resolve this problem as well. When you email over the server log, please include a screenshot of your Plugins from the Vault Admin page.

Thanks,

Tonya

BigBrett
Posts: 217
Joined: Wed Feb 01, 2006 8:45 am

Re: Plugins page on Vault Admin

Post by BigBrett » Wed Sep 01, 2021 12:19 am

Plugin errors solved !

Web site had been altered (by someone else) to bind to one particular IP address so localhost connections would no longer operate.

Tonya
Posts: 718
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Plugins page on Vault Admin

Post by Tonya » Wed Sep 01, 2021 7:15 am

Thank you for providing us with an update. Glad to hear the problem is resolved.

Tonya

Post Reply