Unable to connect to the work item tracking web service

If you are having a problem using Vault, post a message here.

Posts: 3
Joined: Tue Apr 19, 2016 10:16 am
PostPosted: Tue Apr 19, 2016 10:31 am
We are in the process of upgrading our version to 8, and have installed this on a development machine, connecting to copies of the existing production databases running on a development SQL server. Everything seems to work OK, except for Item Tracking.

Under Admin>Item Tracking Projects, when we click on the name or the Categories links, we get "Unable to connect to the work item tracking web service." Groups, Project Access & Milestones links all work fine.

There are no errors thrown in IIS, the event log or in Fiddler for the connection error, so I am not sure what the underlying issue is. Please help, as we would like to move forward with our production upgrade. Thanks!

Posts: 8451
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue Apr 19, 2016 4:02 pm
Check your Vault Server Log and the Vault Pro log from C:\Windows\temp\sgvaultpro. One or both of those log files will list the issue with the connection.

Check also the SQL connection strings in the web.config files under vaultservice and vaultpro in the Vault website. That's usually under C:\inetpub\wwwroot. The encrypted passwords should match.
Beth Kieler
SourceGear Technical Support

Posts: 3
Joined: Tue Apr 19, 2016 10:16 am
PostPosted: Tue Apr 19, 2016 4:55 pm
I verified that the encrypted passwords in the web.config files all match.

I also found the logs and there is not a lot to go on:

----4/19/2016 5:36:49 PM admin--cit-80ql5j1.medpriv.wucon.wustl.edu(10.39.151.85)--SSL Enabled WEB: Could not connect to the work item tracking web service. Tried: https://citappvault.wusm.wustl.edu/, http://localhost/, and
----4/19/2016 5:36:49 PM admin--cit-80ql5j1.medpriv.wucon.wustl.edu(10.39.151.85)--SSL Enabled Uncaught Exception: Exception of type 'System.Web.HttpUnhandledException' was thrown.
Inner Exception: Unable to connect to the work item tracking web service.
----4/19/2016 5:36:49 PM admin--cit-80ql5j1.medpriv.wucon.wustl.edu(10.39.151.85)--SSL Enabled at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
Inner Exeption Stack Trace: at VaultWebLib.RemoteDragnetService..ctor()
at VaultService.Project.Page_Load(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


I get the same error whether or not I use SSL.

Posts: 8451
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Apr 20, 2016 7:46 am
On the Vault server open a browser and try the URLs https://citappvault.wusm.wustl.edu/ and http://localhost/. Do you get a response from IIS on the machine? If not, then check the web.config files for either of those addresses and correct just the first portion so that it reaches IIS.
Beth Kieler
SourceGear Technical Support

Posts: 3
Joined: Tue Apr 19, 2016 10:16 am
PostPosted: Wed Apr 20, 2016 9:26 am
I get responses for both on the server, however, our install is on a shared server, and is not using the Default Web Site, but is configured to use a site called SGVault.

The error listed in the log file is this:
----4/20/2016 10:09:47 AM admin--cit-80ql5j1.medpriv.wucon.wustl.edu(10.39.151.85)--SSL Enabled System.Exception: Unable to connect to the work item tracking web service.
at VaultWebLib.RemoteDragnetService..ctor()
at VaultService.Project.Page_Load(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at VaultWebLib.RemoteDragnetService..ctor()
at VaultService.Project.Page_Load(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

However, I can browse to https://citappvault.wusm.wustl.edu/VaultPro/DragnetWebService.asmx.

Posts: 8451
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon Sep 12, 2016 1:27 pm
Just a note that this issue was dealt with offline.

HS: 244536
Beth Kieler
SourceGear Technical Support

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 4 guests

cron