Vault Enhanced Client on UltraHD

If you are having a problem using Vault, post a message here.

Posts: 167
Joined: Wed Feb 01, 2006 8:45 am
PostPosted: Fri Feb 10, 2017 12:40 am
Having recently acquired an UltraHD monitor, I noticed a few places in the Visual Studio Enhanced Client where the adjustment for the higher DPI is not as it should be.

I have attached screen captures of three items where I have seen problems, there may be more that I haven't seen.

Cheers,
Brett
You do not have the required permissions to view the files attached to this post.

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Fri Feb 10, 2017 9:23 am
Thanks for the report / screen shots. What % for font Scaling are you using?
Jeff Clausius
SourceGear

Posts: 167
Joined: Wed Feb 01, 2006 8:45 am
PostPosted: Sun Feb 12, 2017 11:08 pm
200% on display resolution of 3840 x 2160

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Mon Feb 13, 2017 9:28 am
OK. I'll put that down in the work item.

One other question... What OS is this?

Thanks!
Jeff Clausius
SourceGear

Posts: 167
Joined: Wed Feb 01, 2006 8:45 am
PostPosted: Mon Feb 13, 2017 10:20 pm
Windows 10 Professional

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Tue Feb 14, 2017 10:25 am
Got it. Thx!
Jeff Clausius
SourceGear

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 14, 2018 10:39 am
Just adding an update that high DPI support was added in Vault 10: viewtopic.php?f=13&t=22888&p=78481&hilit=DPI#p78481. The exact change is "Improved support for for High DPI displays and font scaled at 150% to 200%."

I also wanted to add some additional information a customer provided. The results are small, but may help some users.

Modifying the registry will allow VaultGUIClient.exe to run in non dpi aware mode.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\VaultGUIClient.exe]
"dpiAwareness"=dword:00000000

Removing the entry or Setting dword:00000001 enables DPI aware which apparently is the default.

Dpi aware default for MS Visual studio can also be disabled using the same technique above.
See this https://code4ward.net/2016/11/29/visual ... n-highdpi/
Beth Kieler
SourceGear Technical Support

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 2 guests