AD and Email configurations not working

If you are having a problem using Vault, post a message here.

Posts: 7
Joined: Wed Mar 11, 2015 10:21 am
PostPosted: Tue Feb 28, 2017 4:08 pm
1. I've configured the Advanced settings so users can use their AD login to login to vault but it's not working
2. I've configured the SMTP mail properly but it gives an error about verifying that the module supports functionality

Thanks,
John

Posts: 8448
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue Feb 28, 2017 5:21 pm
Are you receiving an error or are no emails received?

Are there any errors in your Vault Server Log or in the Vault Notify log at C:\Windows\temp\sgnotify\sgnotifyservice.txt?
Beth Kieler
SourceGear Technical Support

Posts: 7
Joined: Wed Mar 11, 2015 10:21 am
PostPosted: Wed Mar 01, 2017 10:14 am
This is the error I'm getting from the SMTP Settings form after clicking the test settings link -
Exception: Could not create an object of type 'CDO.Message'. Please verify that the current platform configuration supports SMTP mail.

This is from the log
# SourceGear Vault Server
----2/28/2017 3:42:07 PM sgvaultsystem--()--
System Started
Version 9.1.0.30584
Cache Level = 1
DataBase Buffer Size (KB) = 256
LogFile Path = C:\Windows\Temp\sgvault
Log Level = Quiet
Archive Log = Weekly
ReverseDNS Lookup = True
Maximum HTTP Request Length = 102400
Overwrite Log on Startup = False
Session Timeout = 10080
SGVault Working Directory = C:\Windows\Temp
SGVault Server URL = mail.efaact.com
Identity = APPHOSTING\administrator
----2/28/2017 3:42:14 PM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login
Active Directory authorization for user johnb@apphosting.myefaactelite.com failed: Unknown error (0x80005000)
----2/28/2017 3:52:26 PM johnb--pen-rdshost02.apphosting.myefaactelite.com(10.0.20.19)--SSL Disabled Login failed: FailInvalidPassword
----2/28/2017 3:52:56 PM apphosting\johnb--pen-rdshost02.apphosting.myefaactelite.com(10.0.20.19)--SSL Disabled Login failed: FailNotValidLogin
Active Directory authorization for user johnb@apphosting.myefaactelite.com failed: Unknown error (0x80005000)
----2/28/2017 3:53:11 PM johnb--pen-rdshost02.apphosting.myefaactelite.com(10.0.20.19)--SSL Disabled Login failed: FailInvalidPassword
----2/28/2017 3:54:17 PM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login
----2/28/2017 4:55:06 PM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login
----2/28/2017 4:58:30 PM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Logout
Active Directory authorization for user johnb@apphosting.myefaactelite.com failed: Unknown error (0x80005000)
----2/28/2017 4:58:47 PM johnb--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login failed: FailInvalidPassword
----2/28/2017 4:59:15 PM apphosting\johnb--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login failed: FailNotValidLogin
----2/28/2017 5:00:00 PM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login
----3/1/2017 10:48:29 AM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Login
----3/1/2017 10:48:51 AM admin--fe80::84da:f041:afd6:5a17%18(fe80::84da:f041:afd6:5a17%18)--SSL Disabled Logout
----3/1/2017 10:53:20 AM admin--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailInvalidPassword
----3/1/2017 10:53:34 AM admin--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailInvalidPassword
----3/1/2017 10:53:56 AM admin--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailInvalidPassword
----3/1/2017 10:54:22 AM apphosting\johnb--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailNotValidLogin
----3/1/2017 10:55:12 AM apphosting\administrator--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailNotValidLogin
----3/1/2017 10:55:49 AM apphosting\johnb--c-73-40-37-118.hsd1.va.comcast.net(73.40.37.118)--SSL Disabled Login failed: FailNotValidLogin

Posts: 8448
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 01, 2017 3:56 pm
Is johnb at apphosting-dot-myefaactelite-dot-com in the web.config file for the notify service at all?

Are you able to login to the SMTP server with <same email address>? (We can x-out this email address from this thread when we're done troubleshooting.)
Beth Kieler
SourceGear Technical Support

Posts: 7
Joined: Wed Mar 11, 2015 10:21 am
PostPosted: Wed Mar 08, 2017 11:03 am
No, the smtp service is using the credentials supplied in the vault configuration form to login.
- SMTP Auth User
- SMTP Password

Posts: 8448
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 08, 2017 4:39 pm
The errors posted in the log above must be related to the AD authentication then in Vault.

In the Vault admin web page, click on Advanced Settings, and make sure there is a domain entered. Then all users' login names must match their AD logins, and in their settings you need to select the domain for them to authenticate against. This needs to happen for each user. Do not add the domain name to the users' login names.

You do not need to bother entering a password, because it is passed to AD for authentication. Users cannot change their password through Vault after this is set up. Instead, when AD requires they change their passwords, they can do it through AD since it's doing the authenticating.
Beth Kieler
SourceGear Technical Support

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 2 guests

cron