Picking up earlier version of source

If you are having a problem using Vault, post a message here.

Posts: 7
Joined: Thu Nov 23, 2017 5:50 am
PostPosted: Tue Feb 20, 2018 3:47 am
I doubt this has anything to do with Vault but wondered if you'd had this happen before and might know the cause.

After a Windows 10 update over the weekend (probably a coincidence), one of our developers seems to be picking up a version 7 (3 years old) of a source file not the latest version 12. We've done get latest, removed all the source files and done get latest, removed and re-installed the vault, Still the same.
All the other developers are working OK. All the source and build scripts are in the vault so all users are identical and build source in exactly the same way.
We program in an unusual language called SynergyDE which has no way of knowing anything about vault versions and should be picking up what is in the Pc directory specified. Editing the source in question shows the correct version 12 code but a compile listing (to the point it fails due to the old code) looks to be the version 7 code. The are no other copies of the source file on the Pc. I'm mystified.
Any ideas you might have would be appreciated.
Chris

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Tue Feb 20, 2018 3:28 pm
Your user may have had something affected in the cache file. Have the user clear the repository tree in the cache using instructions posted here: viewtopic.php?t=6.
Beth Kieler
SourceGear Technical Support

Posts: 2
Joined: Thu Jul 13, 2017 8:38 am
PostPosted: Wed Mar 28, 2018 5:13 am
Hi Beth, could this affect any other data btw? I think I need to do this as well.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 28, 2018 1:09 pm
It won't affect the data, but it will affect the statuses. You may get either a Missing or Unknown status. Just set the working folder again, then perform a Get Latest with the option Do Not Overwrite/Merge Later.
Beth Kieler
SourceGear Technical Support

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 4 guests