errors when trying to attach files to Work Item

If you are having a problem using Vault, post a message here.

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Fri May 04, 2018 11:47 am
Hello,

I'm getting errors trying to attach files to Work Items. Not ALL files. Just SOME files. I verified with our IT guy that my attachment size limit is 250 meg.

If I try to attach a 65 meg file I get:

Error: 404
Error on request fileUploadHandler.ashx.
Not found

So I zipped that file to a 13 meg file and tried to attach that.

Error: 500
Error on request fileUploadHandler.ashx.
Internal Server Error

I AM able to attach an 8 meg CSV file.

Thoughts? Thank you!

Tara

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri May 04, 2018 3:34 pm
A good place to start with this will be this KB article, but start with step 2. These are cumulative, so you don't need to undo any as you go down the list.

Also check your IIS log to see if that has any response from the IIS server. That is at C:\inetpub\logs.
Beth Kieler
SourceGear Technical Support

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Mon May 07, 2018 7:01 am
Hi Beth,

Would you please post the link to the KB article again when you get a chance? I'm perusing the KB again to see if I can gather more info. I think I was searching on the wrong keywords last week. Thanks!

Tara

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Mon May 07, 2018 7:53 am
tficken2 wrote:I verified with our IT guy that my attachment size limit is 250 meg.

Hi Tara,

I believe Beth may have meant this knowledge base article, which deals with large file uploads for Vault - viewtopic.php?t=21824

However, since that article covers Vault from the source code control usage, it doesn't cover file attachment uploads from Vault Pro work items. You mentioned the IT guy has an attachment limit. Can you elaborate on that statement?

I would like to compare what IT has done vs. making changes in Vault Pro's web.config for the httpRuntime xml element's maxRequestLength attribute. By default it is set to 10240 or 10MB, but you'll want to make sure it gets set to something larger (say 256000 for your 250MB). Plus there's the IIS request filtering changes that may need to be made as well.
Jeff Clausius
SourceGear

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Mon May 07, 2018 8:25 am
Hi Jeff,

"You mentioned the IT guy has an attachment limit. Can you elaborate on that statement?"

Yes, I should have been more specific. When I log in as Admin and go to Advanced Server Settings, I see that IIS File Upload Limit is set to 250000 KB. Maximum File Size shows "Leave blank if unlimited". Database buffer size is 256 KB.

If you can tell me where the web.config is located, I can ask our IT to send that to me too. Thanks!

Tara

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Mon May 07, 2018 8:44 am
Tara,

That is the file upload limit for the 'source code control' files. Vault Pro work item uploads have their own configuration, and unfortunately, there's no UI for it.


To change the setting for Vault Pro work Item attachements:

  • In your Vault Server installation directory, find the <install_dir>/VaultPro/web.config file
  • Using a command prompt with elevated administrative privileges, open the file in a text editor
  • Find the httpRuntime xml element
  • Change the maxRequestLength attribute from "10240" to "256000"
  • Save the file
  • (Optional) - as a precaution may want to restart the VaultPro IIS Application pool

Try the upload again. Did that work?

There may be another tweak that is needed in the IIS Administration tool (step 3 in the KB article) , but let's cross that bridge only if needed.
Jeff Clausius
SourceGear

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Mon May 07, 2018 12:33 pm
Getting closer. We changed maxRequestLength to 256000.

I can now attach files that are 27 meg to Work Items, but not 32 meg or greater.

I fear we may need to invoke step 3. Since we've already directly edited the web.config, I guess we would be inclined to go with 3c. Please confirm that we should move forward with that? Thanks!

Tara

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Mon May 07, 2018 3:01 pm
Yes... The IIS Request Filtering is set to 30MB by default. So, that will need to be reconfigured as well. Unless you're running a rather old version of IIS/ Windows Server, step 3B should do the trick.
Jeff Clausius
SourceGear

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Tue May 08, 2018 9:27 am
That did it! I can now attach large files to my Work Items. Thanks folks!

Tara

Posts: 3544
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Tue May 08, 2018 12:43 pm
We're glad to see the issue has been resolved.
Jeff Clausius
SourceGear

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 7 guests

cron