Server Install problem

If you are having a problem using Vault, post a message here.
Post Reply
mazielvcLSES
Posts: 2
Joined: Thu Jun 20, 2019 10:51 am

Server Install problem

Post by mazielvcLSES » Thu Jun 20, 2019 12:20 pm

I'm trying to install Vault Pro Server and I get the following error (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
Bellow is the log file of the installation.
I have SQL server express and I used the .\sqlexpress as SQL Server.
SQL Server Browser is running, I ahve added sqlbrowser.exe and sqlsrvr.exe to the firewall.
Any ideas?

Thanks,

Log started at 20 Jun 2019 - 14.12.25

Custom action assembly location: C:\inetpub\wwwroot\VaultService\bin\CustomActionExe.exe
Custom Action version: 10.0.2

FileVersionInfo: File: C:\inetpub\wwwroot\VaultService\bin\CustomActionExe.exe
InternalName: CustomActionExe.exe
OriginalFilename: CustomActionExe.exe
FileVersion: 10.0.2.30936
FileDescription:
Product:
ProductVersion: 10.0.2.30936
Debug: False
Patched: False
PreRelease: False
PrivateBuild: False
SpecialBuild: False
Language: Language Neutral


The commandline args as passed in to us:

/TARGETDIR=C:\inetpub\wwwroot\VaultService\
/TARGETDIR2=C:\inetpub\wwwroot\VaultPro\
/WEBDAV=C:\inetpub\wwwroot\SgDav\
/PARAMS=
/DROPDB=
/UPGRADE=
/ADMINPW=
/SQLSERVER=
/WINAUTH=1
End commandline args.

Found local name of NT AUTHORITY\NETWORK SERVICE for Network Service account.
See if we need to do an upgrade or an install...Configuring your new Vault Professional Installation
Entered CreateCryptoRegistryValues.
CreateCryptoRegistryValues completed successfully.
Found SOFTWARE\Wow6432Node
Requesting the IIS Process User...
Found local name of NT AUTHORITY\NETWORK SERVICE for Network Service account.
The selected website is 'Default Web Site'
You chose website: 'Default Web Site'
Modifying VaultAppPool...
Properties: Id=ApplicationPoolIdentity, .NET=v4.0, Mode=Integrated
Modifying VaultShadowFolderAppPool...
Properties: Id=ApplicationPoolIdentity, .NET=v4.0, Mode=Integrated
Modifying VaultIndexAppPool...
Properties: Id=ApplicationPoolIdentity, .NET=v4.0, Mode=Integrated
Modifying VaultNotifyAppPool...
Properties: Id=ApplicationPoolIdentity, .NET=v4.0, Mode=Integrated
Modifying SgDavAppPool...
Properties: Id=ApplicationPoolIdentity, .NET=v4.0, Mode=Classic
Creating Applications in IIS for web services...
VaultService application created.
Creating Applications in IIS for Vault Professional Work Item web services...
Vault Professional application created.
Creating Applications in IIS for VaultShadowFolder web services...
VaultShadowFolder application created.
Creating Applications in IIS for Find in Files Index web services...
VaultIndexService application created.
Creating Applications in IIS for Notification web services...
VaultNotificationService application created.
Creating Applications in IIS for SdDav web services...
SgDav application created.
Creating Virtual Directories...
VaultService Virtual Directory created.
Vault Professional Virtual Directory created.
VaultShadowFolder Virtual Directory created.
VaultIndexService Virtual Directory created.
VaultNotificationService Virtual Directory created.
SgDav Virtual Directory created.
Exit SetInstallationSettings() success
Entered GetServerBindings()
Subkey is open
Exit GetServerBindings()
Requesting Admin user password... Hashing the admin pw
OK
Connecting to the SQL Server...ConnectToDatabase() failed: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

Tonya
Posts: 668
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Server Install problem

Post by Tonya » Thu Jun 20, 2019 12:52 pm

During the installation process when prompted to Connect to SQL Server - Which option did you chose?

Windows authentication will use the account specified in the IIS Process Model. SQL authentication will require you to enter in a SQL sysadmin account such as sa, but Vault will create its own user called sgvaultuser that it will use after the installation.

Can you please confirm the user specified has SQL Server admin rights?

Thanks,

Tonya

mazielvcLSES
Posts: 2
Joined: Thu Jun 20, 2019 10:51 am

Re: Server Install problem

Post by mazielvcLSES » Thu Jun 20, 2019 1:31 pm

Thanks for your reply.
I tried connecting using Windows Authentication.
The IT manager says there is no sysadmin created for SQL and I can create one if needed (Id on't know how yet)
He also says there is no Active Directory set up, no domain, not even a local DNS server and may complicate things.
Should I create a sysadmin before continuing?

Thanks,

Tonya
Posts: 668
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Server Install problem

Post by Tonya » Thu Jun 20, 2019 1:44 pm

Yes, you will need to setup a SQL Server administrator before you can install Vault.

I have copied below the Vault Server installation Guide that should assist you:

http://sourcegear.com/vault/documentati ... index.html

Tonya

Post Reply