Vault Pro 9.1 Hang on Startup After Selecting Repo

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 2
Joined: Wed Jun 14, 2017 9:17 am
PostPosted: Wed Jun 14, 2017 9:43 am
We just upgraded from Vault 6 Pro to Vault 9.1 Pro.
Several of us have noticed that at times when we log into the Vault Professional Client it hangs with the spinning disk. (Running on Win 7) This happens after:
  1. Launch the Vault Pro Client
  2. Log in
  3. Select the repository
  4. Watch spinning disk for as long as desired
Most of the menu options are disabled. Abort is enabled but clicking it does nothing. It never resolves by itself. The solution is to click the X to close the program and try again. Sometimes several times. But eventually it goes right in.
We never had this problem using Vault 6.
This is happening to more than 1 user.
Once we get past the initial startup issue the client seems to work fine.
I tried turning off "Check for latest Vault version at startup" but this didn't change the problem.
I tried turning off "Use Expect: 100-Continue headers (for low latency networks)" but I still experience the problem.
Once connected successfully, I tried selecting File->Disconnect from server and then File-Connect to server to see if I could get it to fail but I could not replicate the failure this way. To replicate the failure I have to close out of the program and open it again. Granted, I only tried this half a dozen times but when opening the program it seems to fail about 50% of the time.
Thanks in advance for your help!

Posts: 8334
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Jun 14, 2017 12:28 pm
Try out the suggestions in this KB article: viewtopic.php?f=13&t=22633.
Beth Kieler
SourceGear Technical Support

Posts: 2
Joined: Wed Jun 14, 2017 9:17 am
PostPosted: Mon Jun 26, 2017 6:38 am
Thanks for the suggestions. I went through the list and tried everything I could but I am still seeing the problem.
I did notice on the step 5 that the query SELECT COUNT(*) FROM sgnotify.dbo.events; is still showing 7 even though I cleared out event details and restarted the Vault Notification App Pool. (SELECT COUNT(*) FROM sgnotify.dbo.eventdetails; shows 0)
Just to reiterate, we did not see this problem on Vault 6 with the same server and same SQL server and database.
Thanks!

Posts: 3412
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Mon Jun 26, 2017 8:59 am
Matthew,

Do you have the auto-login / auto-choose repository option enabled? If not, you could try this:

1) Start up the Vault GUI Client.
2) Log in to the server, but DO NOT choose a repository. Hit Cancel on that dialog.
3) Next go to Tools -> Options -> Network Settings. UNCHECK the 'Request database delta on repository cache miss'.
4) Click OK on the options.

Now try to log in and choose a repository.
Jeff Clausius
SourceGear

Return to Support (Vault)

Who is online

Users browsing this forum: Bing [Bot], kha, Yahoo [Bot] and 10 guests